18

Usually my Mac performs pretty comfortably but for the last hour or so it's been almost unusable. When I type it takes a few seconds to actually display what I've typed or just beachballs for a little while. If I try to open a new tab in Safari it takes about half a minute to actually appear.

When I opened Activity Monitor to see if I could work out what was happening "softwareupdated" was taking 100% CPU and Memory Pressure is in the red. I tried opening the App Store application to see if that would tell me but the application just opens but won't draw any content.

enter image description here

I didn't tell my Mac to update anything, and the App Store app seems useless right now, so how do I find out what is it doing that is causing this?

  • mine was busy updating Pages, Notes & Keynote in the background [for no real apparent reason as they were supposedly already up to date], whilst I was trying to get it to find 10.10.4 & iTunes. I waited it out then rebooted. All went back to normal & I got both the OS X & iTunes updates then. – Tetsujin Jul 1 '15 at 8:08
  • 2
    Also - check what you have set in System prefs > App Store - there's a whole bunch of background update options in there. – Tetsujin Jul 1 '15 at 8:10
  • I had the same issue. CPU 100%. Just kill that process in Activity Monitor. Then check for update, it will work as expected. – Pratik Jul 1 '15 at 10:07
15

If you open the Console application I believe it defaults to "All Messages" which might not provide any useful information.

However if you open the Console application, then open the "/var/log" option at the bottom of the left-hand source pane you should find an entry for "install.log". If you select that you should see some information on what softwareupdated is actually doing, or trying to do, to your machine.

| improve this answer | |
  • 1
    File FWAVC.framework/Versions/A/FWAVC is not in either expected pre- or post-patch state for (package: com.apple.pkg.update.os.10.10.4.14E46.delta) Jun 30 17:27:56 new-host-2.home softwareupdated[388]: Package Authoring: finalSHA1String = 2276768b20f52471f8097c493254cae3f0e2f33f, digest = 1edd7f907902ac44e0d895302abe4fa7d8393e94 (package: com.apple.pkg.update.os.10.10.4.14E46.delta) – Jérémie Jun 30 '15 at 21:34
  • Yup, that's the same error messages I've been getting. Logged that as a separate question here. apple.stackexchange.com/questions/193814 – Alistair McMillan Jun 30 '15 at 21:43
  • 1
    Very helpful (+1). Led me straight to something going wacky (thousands of log entries) with HP Printer software trying to update over and over Connected printer: MANUFACTURER:HP;MODEL:Photosmart C4700 series and Printer HP_Pdf2Pdf1 does not require an update. – D. Woods Aug 5 '19 at 15:49
4

I had the same problem. Fixed this way:

  1. go to system preferences
  2. click on app store
  3. un-click "Automatically check for updates"

Problem solved!

| improve this answer | |
  • Is that really fixing it though? Isn't that like taking your car to the garage cause its making a funny rattling noise while you drive and the mechanic saying "The way to fix this is to stop driving your car and take the bus instead."? – Alistair McMillan Jan 5 '18 at 21:51
  • This worked for me! Thanks! – Maygan Lightstone May 3 '19 at 3:33
1

For me kill -9 softwareupdated led to a requester to reboot the mac being shown. After the reboot the installation started. Nothing seems to be broken at the moment, but now I am a bit scared.

| improve this answer | |
1

I solved this by rebooting and installing OS X Yosemite 10.10.4 Combo Update.

Source: https://discussions.apple.com/message/28476636#28476636

| improve this answer | |
  • 2
    Welcome to AskDifferent! Please expand your answer with some explanation of the solution to the problem, in addition to the links you found. Answers which rely on links alone may end up being deleted. – IconDaemon Jul 1 '15 at 11:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .