23

When I enter the text message / SMS "app" and tap on the input field a keyboard pops up. When I'm done writing and have sent the message I would like to dismiss the keyboard again. I haven't found out how to so this.

The best work around I have found is to leave and enter the conversation. But surely there must be a better way. How can you do this or is it even possible at all? I have tried almost everything.

16 Answers 16

16

This is not possible at all right now. Like you said, you can back out and go in again to dismiss keyboard. Other option is to tap the 'edit' button on top right. That will dismiss keyboard but it will go in edit mode. When you cancel out of edit mode keyboard will come back.

Apple should do something to easily bring up and dismiss keyboard...

Update: With iOS 5, you can swipe messages down all the way pushing the keyboard downwards. Initially I thought, "why not just swipe down the keyboard itself to dismiss?" But now it makes sense because you start scrolling down to see previous messages and keyboard naturally goes away when you do that.

  • 4
    Apple should do something to easily bring up and dismiss keyboard... Yup. It's downright annoying when you need to read a long text message. – George Marian Aug 8 '10 at 6:38
  • Yeah. Whatsapp does it fine for example. – gsharp Dec 6 '10 at 15:29
  • 1
    in iOS5 you able to hide this with swipe messages down – Eir Nym Oct 23 '11 at 16:03
  • Even in IOS5 it is not possible to hide the keyboard swiping if the message you are typing grows big enough to hide the conversation list. – Yuri Ghensev Jul 10 '12 at 21:04
4

If you turn your phone sideways, the keyboard is slightly different and has a few different command keys on the sides. The one next to "return" will hide the keyboard. Then simply turn your phone back up and the keyboard stays hidden until you click for it to come back. I found scrolling up in the message will hide the keyboard. But this only works in the SMS screen, it does not work in apps like Google Docs, whereas turning it sideways does.enter image description here

  • 3
    Requires iPhone 6/6s Plus – grg Dec 2 '15 at 19:24
2

Double-tapping the message area with one finger minimizes the keyboard.

  • 1
    A google search 6 years later brings up this thread. This is the real resolution. – Nazadus Mar 31 at 17:31
1

'backspace' then all sms's then back to conversation and the keyboard appears minimized.

1

If you have an apple bluetooth keyboard you can hit the eject button on it to close/open it, other than that I don't think you can.

1

You can touch a spot right between the message text field and where the messages display and drag (not swipe) down to hide it. It's a little tricky to get the right spot, you'll have to find it through trial and error. Good luck!

0

This gets on my nerves too but if you tap edit in the top right, the keyboard minimises until you press cancel . Although it doesn't let you load earlier conversations, it's useful if you want to read over a long text that you're replying to or something.

0

I just play around with it trying to hide it and I found out how to hide the keyboard. Pull down the conversation in a fast motion. Like swiping down the page to earlier messages quickly. The keyboard will go away. I hope it helps! :)

  • 1
    This works now in iOS 5, the original question was related to iOS 4. – nohillside Oct 23 '11 at 13:55
0

all you have to do is toggle the keyboard downward to dismiss it and it will go away just gently motion the keyboard down with your index finger and it will go away

0

Press and hold the keyboard icon and press “dock” to move the keyboard out of your way so that you can see what you are typing.

0

Solution: Use the named touchesBegan like below

override func touchesBegan(_ touches: Set<UITouch>, with event: UIEvent?) {
        view.endEditing(true)
}
0

Found new trick in ios 13 to hide the keyboard.

  1. From the page where you want to hide the keyboard, open notification area by sliding the screen from top.
  2. Swipe right to go to Search panel from notification area.
  3. Click on search input box.
  4. Now just swipe up the screen from down to close search panel.
  5. now keyboard will be disappear from the application.
-1

When you want to dismiss the keybord you type "Return".

-1

Rather than swiping downward, take your index finger and drag downward on the left side of the message area.

-2

Tap the area where the messages are with 2 fingers, this minimises the keyboard.

  • This doesn't work. – zigg Jul 15 '13 at 0:21
-2

My friend simply had to reset my settings...and the keyboard panel went away

  • This question is from 6.5 years ago and already has an accepted answer. Are you sure you're answering the correct question? – fsb Mar 21 '17 at 20:25
  • Welcome to Ask Different and thank you for your answer. :) Assuming you did mean to answer this question, short answers such as this don't really provide enough detail or context to help many users. For example, your answer doesn't explain what settings were reset, nor how they were reset. So, as it stands, it's not very useful. Could you edit your answer (there's an edit link below it) to provide the additional detail? If you're unsure of the details, then it may be best to just delete the answer. – Monomeeth Mar 21 '17 at 23:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .