11

I downloaded iOS 8.4 this morning, and activated Apple Music. I started browsing, and found an album I wanted to add to my library. When I tried to add it, I was told that I needed to enable iCloud Music Library, and was directed to the settings.

However, when I try to enable it in the settings, I get an error saying that "iCloud Music Library can't be enabled". No further details are available. This error occurs whether I choose to "Merge" or "Replace" my device's current library.

What do I need to do to get past this error?

11

Keep trying. After toggling the setting to enable it a dozen times over twenty minutes, it finally worked. This appears to have been a temporary problem associated with the launch.

  • 1
    Turning airplane mode on then off worked for me. – user134212 Jun 30 '15 at 16:01
  • 1
    Just keep trying. It worked on my 30th attempt. As others have mentioned, Apple is probably getting slammed with people activating their free trial to Apple Music. – jarrodedg Jun 30 '15 at 16:02
  • I rebooted the phone and it worked. – user134216 Jun 30 '15 at 16:07
  • Turn on and off airplane mode ... It worked for me – user134217 Jun 30 '15 at 16:07
3

From iMore

  1. Launch Settings from the Home screen.
  2. Tap Music (note, the icon has changed colors).
  3. Toggle iCloud Music Library to On.
  4. Choose if you want to Replace or Merge your library. (I ultimately chose Merge when it worked).
  5. If you get the error again, dismiss it.
  6. Repeat steps 3-4 until it works.

settings

0

Wait until tomorrow.

There are millions of people trying to enable, signing up and "force retrying" to activate Apple Music at the same time; from Apple's point of view this probably looks as a DDoS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .