14

I have

  • iPhone 5 (with iOS 8.3)
  • MacBook Pro Early 2013 (with OS X Yosemite 10.10.3)
  • iPad Air (with iOS 8.3)

My iPhone is paired with the MacBook, so e.g when my phone rings, I can see it in my computer. But when I want to AirDrop photos from my iPhone the MacBook, then I can't see the MacBook in my iPhone AirDrop targets.

I can see the iPad, I can see my wife's iPhone, but not the MacBook.

On MacBook, I can see the iPad, my wife's phone and even my iPhone and I can drop to there, but not the other way around.

Before I started troubleshooting, the iPhone and MacBook were mutually invisible (I only saw iPad from both). After a while of trying things and sending files back and forth, my MacBook started to see the iPhone, but I did not manage to make it work from the other way. Still, the iPhone seems to be much "less" visible than the iPad - which I see almost instantly and always, the iPhone only seems to appear after a while.

Just to make it clear:

  • both iPhone and MBP have BT turned on
  • both have AirDrop visibility set to Everyone

I would be glad for any suggestions to fix this - what settings to check, logs, whatever.

  • 1
    I have the same problem. Is there a solution to this? My iPhone 6s doesnt show my MAC from 2013 on airdrop settings :( – user159106 Nov 26 '15 at 15:58
  • It now started to work for me, but hard to tell why - I am on different wifi, I have iPhone6s instead of 5 (and iOS 9) and some time has passed. – Michal Nov 26 '15 at 16:21
  • I started my Mac and the iPhone 5c and now both shows up in AirDrop – Kuldeep Jain Apr 5 '16 at 10:34
  • "AirDrop is a riddle wrapped in a mystery inside an enigma." -- Sir Winston Churchill. – calum_b Apr 16 '16 at 11:13
5

Steps 3 and 4 are the trick!

Similar issue:

  1. Can send file from MBP to iPad.
  2. Can not see MBP on iPad* airdrop screen.

Fix that worked for me:

  1. On iPad: turn on Wifi, Bluetooth and AirDrop (share with Everyone)
  2. On Mac: turn on Wifi, Bluetooth and AirDrop (share with Everyone), then try to share the file(s) on AirDrop
  3. On Mac: Bluetooth > Browse files on Device; select Jeff's iPad, then 'Browse'; notice it connects, but then it drops right after with the message "The device does not have the necessary services" and
  4. On iPad: observe that 'Mike's MacBook Pro' shows on AirDrop MBP', despite of the error (another error message might be shown under the MBP's name)
  5. On iPad: send pictures/videos to Mac.
  6. [extra] On iPad and MBP: for security reasons, turn off AirDrop (and maybe Bluetooth too) once you're done!

    *Obs: it should work on iPhone too; I upvoted this answer since it helped me to find this solution .

  • 1
    I tried the steps 3+4 and it seemed to work. I will see if it will help multiple times and if so, will accept your answer. – Michal Sep 22 '16 at 12:49
  • 1
    When I did step 3, my MacBook appears on iPad. – htanata Jul 11 '17 at 1:26
4

For AirDrop to work, you need

  1. Wi-Fi and Bluetooth on —although you don't need to be connected to the same network for AirDrop to work.
  2. AirDrop activated —probably the "Everyone" setting will help with visibility on iOS.
  3. If your Mac is older than 2012, you may have some issues.
  4. You have to be closer than 30 feet (9 m).
  5. You may wish to check your firewall, but given your specific situation —you see the iPad— that may not be a problem.

Check this document in case I missed something.

  • 1
    Thanks for answer. I did again run through your checklist and I have to confirm that all items are checked. Both have WiFi&BT on, both seen by Everyone. Mac is Early 2013. Devices just next to each other. Firewall disabled. I did try to run Console App, which shows some activity and some error, but I am not sure if it's related - I would like to confirm before posting, but I can't match the given IDs and addresses to anything (e.g. phone MAC or IP address, – Michal Jun 30 '15 at 8:59
  • 1
    It may be relevant to consider that the iPhone won't have Wi-Fi / Bluetooth connectivity always on to save battery. That may account for it not appearing instantly (if it is locked while you search for it). – Jaime Santa Cruz Jun 30 '15 at 16:00
  • 1
    So I run Console again at home. I see some entries regarding discovery of the iPad, but nothing which looks like relared to the iPhone. – Michal Jun 30 '15 at 20:59
  • 1
    I know that when iPhone/iPad is locked, it's not shown. It works quite nicely with my iPad and my wife's iPhone - lock, disappear, unlock, they appear again. But still no joy between my iphone and MBP. – Michal Jun 30 '15 at 21:01
  • 1
    Sorry to hear that, it works almost instantly on my setup (iPhone 6 iOS 8.4, iPhone 5 iOS 8.3, rMBP late 2013 OS X10.10.3). – Jaime Santa Cruz Jun 30 '15 at 21:11
3

Turning off firewall Worked for me after searching the web for months and trying 100's of solutions!!!! FINALLY!!

2

Try sending a file to the iPhone from the Mac.

My iPhone was able to discover my Mac by doing so when I was having issues sending a file to my 2012 MacBook Air (OSX10.11.3) from my iPhone6S Plus (iOS9.3.2), leading me to this page. I tried all the settings and workarounds mentioned on this page and my Mac was able to discover my iPhone, but not vice versa.

2

I was having the same issues as described in this post. That is:

  1. Can send file from Mac to iPhone.
  2. Can not see Mac on iPhone airdrop screen.

To "fix" it I did this:

  1. On Mac: Stopped a utility called "TokenLock". (it uses bluetooth).
  2. On Mac: Forgot iPhone.
  3. On Mac: Re-pair to the iPhone.
  4. On iPhone: Accept pairing.
  5. On iPhone: Observe message that "Connection Unsuccessful 'Mike's MBP' is not supported"
  6. On iPhone: Observe that despite message Mike's MBP became available for Air drop on iPhone.
  7. On iPhone: send pictures to Mac.
1

After pulling out hair for almost an hour, tried the following which solved the issue.

My Devices are iPhone 5s running iOS.9.2.1 and Macbook Pro running Yosimite 10.10.5

  1. Sign in to iCloud account on Mac Book Pro system prefernces -> icloud
  2. Sign in to same iCloud Account on your iOS device
  3. restart your iOS device
1

There are number of methods to get it working so try them out one by one what works for you.

  1. Try creating new user in mac and test airdrop with
    -icloud signed out
    -icloud signed in
  2. Reset PRAM ans SMC
  3. Try switching on/off bluetooth/wifi on both the devices.
  4. Network reset in iPhone.
  5. Test the same machines in different wifi at different location sometimes it is an issue of wifi router also. // This has happened with me.
  6. Check firewall in mac and disable it temporarily.
  7. Try without connecting to any network on both the devices i.e. forget wifi on both devices but enable wifi/bluetooth on both.
  8. Try it in Safe mode.
  9. If you have another mac available then try to airdrop with mac to mac.

Happy airdrop debugging :P

0

found out that if you are using a VPN there is a good chance that you will lose your ability to use airdrop

-1

try to remove the stealth mode on your firewall settings and uncheck the block all incoming connections in that same window on top. it should work then

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .