2

I have a Late-2011 Macbook Pro (4GB RAM) that has been running slow for several OSX cycles, and since Mavericks it's been unbearable (spinning beachballs whenever you do anything). I tried upgrading to Yosemite hoping this might improve performance; no dice. I've decided to try clean-booting Yosemite to see if this improves things.

I've been following instructions here to do a clean install and here to create a bootable flash drive. Drive creation seems to work fine: it has the correct GUID partition table, terminal command exits with the copy complete; done output, the disk shows up in the Finder as "Install OSX Yosemite", etc. When I restart the computer holding Option, the installer shows up as a bootable disk (unlike the question here).

My problem is that when I then click on the installer, I get a loading bar for some seconds and then the screen goes to a circle with a slash through it. It's the same behaviour detailed here but note that I have verified that my disk has the correct GUID partition table. I also tried resetting PRAM, to no effect.

Any suggestions welcome.

  • MBP slow true multiple OS X versions. I would say you have some app in your User folder that does that, since OSX installs would not touch that. I use the Activity monitor to see who, and Console log to see what. – Ruskes Jun 28 '15 at 22:07
  • I've checked the activity monitor and can see no program whose memory / CPU use could explain the slowness, other than kernel_task and spotlight helpers. That doesn't mean it's not caused by a user program, only that there's nothing that jumps out to me. Hence why I decided to try the clean install. – tsawallis Jun 29 '15 at 9:56
1

The boot problem seemed to have been related to a disk error on the hard disk of the mac. I ran the disk utility and it detected a problem with the macbook's HDD (something with doubled file links), which it then repaired. The computer was still slow and unresponsive after the disk repair. After that the boot from the USB worked fine, and I was able to clean install OSX Yosemite.

I recovered the computer from my time machine backup, excluding applications, and now the computer is noticeably faster and more responsive. I don't know whether a specific application or accumulated OSX sludge was responsible for the slowdown, but I'm happy I went through the pain of the clean install.

  • Disk errors are not fixed by reinstalling the OS. Issue this command diskutil info /dev/disk2 | grep -i smart and post your results. I think your drive is physically failing. – Allan Apr 20 '16 at 12:10
  • Sorry for the late reply. This command just returns SMART status: Not Supported... though you are of course likely correct. Several weeks after my reply above the computer is again running terribly. I imagine it's a disk problem. – tsawallis May 25 '16 at 7:49
1

I've recently replaced my Macbook's hard drive with a new SSD to speed up its performance. For my purpose, I had to do a fresh install of OSX Yosemite on the new SSD, and I also encountered the "no" symbol or "prohibited" symbol when I tried to load the OSX installer through my bootable USB.

I tried rebooting the computer and re-downloading the OSX installer files on my USB a couple of times but it made no difference. The USB seemed perfectly fine when I ran the Disk Utility first aid and the Terminal didn't output error codes either.

Later, I found out the problem actually came from creating the bootable USB through Terminal. Somehow the installer files got corrupted when making the USB bootable. The solution is to use a third-party application like Install Disk Creator to do job instead of using Terminal. It worked for me and I was able to install OSX Yosemite afterwards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .