0

On iMac with Yosemite, my screensaver has lost the option to use photos. Where there should be an option to select a photos folder there is only a bar "Screen Saver Options" i.e. color, speed etc of the cg saver options which are still available. If I try to select a photo option e.g. "Photo Mobile" I get an endless rotating color disk.

I have tried reinstalling Yosemite, deleting all screensaver-related plists in preferences and rebuilding iPhoto, with no luck.

Any suggestions?

1

[[Note: if you see a spinning "Beachball" it may be that your photo library is quite large so the processor may need time to display everything. You may find that placing photos you wish to display in a folder stored outside of iPhoto or the Photos app will improve performance.]]

Assuming you have photos in a folder or imported into the Photos app, this procedure should help.

  • Go to System Preferences
  • Select Desktop & Screen Saver
  • Select the Screen Saver tab
  • Choose one of the photo type screen saver options such as Floating or Reflections
  • From the Source pop-up menu select your source from Photos or a folder with your pictures by selecting Choose Folder... or Photo Library...

Screen Saver Settings Yosemite

Photos selection

You must log in to answer this question.

protected by Community Jan 29 '16 at 14:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .