0

The Wi-Fi on my MacBook Air 11″ 2011 only connects within 10 feet of the router. Other Air works over 45 feet away. Happened after upgrade to Yosemite, now 10.10.3.

Card Type:  AirPort Extreme  (0x14E4, 0xE9)
 Firmware Version:  Broadcom BCM43xx 1.0 (5.106.98.100.24)
 MAC Address:   60:c5:47:02:58:92
 Locale:    FCC
 Country Code:  US
 Supported PHY Modes:   802.11 a/b/g/n
 Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165
 Wake On Wireless:  Supported
 AirDrop:   Supported
 Status:    Connected
0

2 Answers 2

1

You published the hardware information which is useful, but hardly to change with upgrade to YOSEMITE.

First lets check the current condition:

Hold the Alt key and click on WiFi icon.

You get something like this:

wifi

RSSI is (Signal strength including the noise (disturbance)) this is confusing but the lower the number the better.

Transmit Rate- the higher the better (minimum 10)

MCS Index- the higher the better (minimum 5)

There are some Apple provided analytical tools to take look at your WiFi.

If you hold the alt key and click on the WiFi symbol, at the bottom of that list there is a "Open Wireless Diagnostics". Enter your log in password and continue. Let it run till it ask you what to do next. Use the "Monitor my WiFi connection". Let it run and move the MacBook around closer and further from the router. Stop it if nothing happened.

I get the "Crowded WiFi channel" on mine, to many of my devices and neighbors on same channel.

On Yosemite hold the "alt" and click on WiFi, then select the "Open Wireless Diagnostics". In menubar Window tab and select the scan.

Once you have the result sort it by Channel to see how crowded it is.

Here is what I get:

enter image description here

As you can see aside of my self been on channel 11, there are to many others on it as well. Go to your router setup and change the channel to less crowded one.If you have 5g WiFi then switch to it.

3
  • also El Capitan has vastly improved network reliability
    – Macmaniman
    Jun 28, 2015 at 17:52
  • My MCS was '0'. I turned off Bluetooth but to no avail. I am using 2.4Ghz and 802.11n protocol. Diagnostics says remove interference. What I don't understand is that it worked perfectly well before installing a clean version of Yosemite. Jun 29, 2015 at 16:20
  • What is your RSSI ? and the Transmit rate and channel crowding ? As Diagnostics says, remove that interface, and I would remove all others and start over creating new one. Yosemite is known to have WiFi problems, but we could solve that. Blue tooth has nothing to do with WiFi. The fact you say it works when close to the router, means it works, but it has to much interference sources so it stops working when you move away from the router. This should be clearly shown in the RSSI numbers. Like it should be RSSI <50 when close, and > 80 when it is loosing it.
    – Ruskes
    Jun 29, 2015 at 17:33
0

I have a late 2012 Macbook pro and changing the Wireless channel width from auto and/or 80MHz to 40MHz solved my problem. I was literally about to bang my head against the wall by the time I came across this solution. You can read more about it at this guy's blog:

https://hmijailblog.blogspot.com/2018/05/macbook-2013-vs-80-mhz-wifi-channels.html?showComment=1561123985127#c6468315321364816177

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .