I'm using OS X Yosemite (10.10.2) and recently I have been unable to drag or move any items on the dock. Right clicking them gives no option for "remove from dock", and the icons cannot be rearranged. New icons cannot be added, old icons cannot be deleted.

I have tried restarting, and resetting dock preferences to default, and killall Dock, as suggested by earlier askers. None of it works.

I heard about problems with PushBullet - but I do not have PushBullet. Just in case, I deleted a lot of random applications. Still nothing works.

I've tried various commands from lots of answerers on other questions. I've consulted the Mac Help pages. Nothing.

Does anyone know how I can resolve this? After resetting my Dock in an attempt to fix it, it is now filled with the default icons too. This is really limiting my productivity.

  • Admin account, I presume? I'm wondering if perms have gotten screwed somewhere… maybe see apple.stackexchange.com/a/42107/85275
    – Tetsujin
    Commented Jun 27, 2015 at 19:28
  • @Tetsujin will this reset my password? Commented Jun 27, 2015 at 19:52
  • Have you tried deleting com.apple.dock from ~/Library/Preferences?
    – MorganR
    Commented Jun 27, 2015 at 19:55
  • @MorganR I think I already have tried it, because I don't see it in the directory. I do see com.apple.dock.plist, should I try deleting that too? Commented Jun 27, 2015 at 19:57
  • 1
    @MorganR Just did that and restarted. Still unable to move icons. Commented Jun 27, 2015 at 20:00

4 Answers 4


Make sure the Dock is not locked:

defaults delete com.apple.Dock contents-immutable && killall -HUP Dock
  • Unfortunately, it's not locked. I've run that command before, but I ran it again just in case - still no change. Thanks for the answer, though. Commented Jun 27, 2015 at 19:20
  • I had to call killall Dock twice before changes applied. (macOS 10.13.2) Commented Dec 12, 2017 at 14:39

In Apple menu choose forcequit: Finder is in the list, choose relaunch.

  • Unfortunately this was not the issue. Commented Jun 27, 2015 at 19:51

go to system preferences, click parental controls, select your user account, click other, deselect "Prevent the dock from being modified"

  • It appears the OP has an admin account, so it can't have parental controls applied to it; also, you cannot unlock parental controls if you're not the admin. Commented Aug 29, 2016 at 19:21

For what it's worth, simply going to the Parental Controls section of the settings, unlocking it to modify (even though it was already off), then closings the settings window, fixed it for me.

  • Was this enabled on an admin account?
    – bmike
    Commented Apr 12, 2017 at 22:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .