1

Is there an option / setting that allows you to only output audio via the headphone port on your macbook / pro / air ?

So that if i had my headphones on and then pulled them out of the laptop the audio wouldnt come out of the speakers until i turned off this option.

Background : Im running a MBP with 10.9.5

1

When you switch audio outputs, the volume level reverts to whatever level it was at when you last used that output. That means that muting the internal speaker before plugging in headphones should be enough to stop audio from playing through the speaker if you disconnect your headphones.

If you want to keep the speaker disabled even if you hit any volume controls, you can use Soundflower. It's an extension designed to let your Mac record its own audio output, which it does by creating virtual input and output options that feed directly into each other. That means that you can hold down Option, click on the volume icon in the menu bar, and select one of the Soundflower options as your audio output before plugging in your headphones and selecting them as the output device. If your headphones get disconnected, your audio output will default to Soundflower, which doesn't send anything through the speaker. To re-enable the speaker, just Option-click on the volume icon in the menu bar and choose the built-in speaker for output.

| improve this answer | |
  • Hadn't thought of that one. Nice. Only trouble is when you get to Yosemite, Soundflower is getting a bit long in the tooth. I had to abandon it. – Tetsujin Jun 27 '15 at 13:58
  • @Tetsujin I looked around on the GitHub page and found a beta that claims to be kext-signed to work with Yosemite. – user24601 Jun 27 '15 at 14:02
  • I've tried it - still manages to kernel-panic. The only 'utility' to push my Mac over in years. I'm staying clear for now. I wish Rogue Amoeba would take it over fully & even charge a couple of bucks for it. They have the skills, looking at their other work, & I'd be happy to pay for a stable version. – Tetsujin Jun 27 '15 at 14:11
  • Looking at RogueAmoeba's site, they probably abandoned Soundflower because it felt too similar to Audio Hijack. – user24601 Jun 27 '15 at 14:15
  • I think they were given [sold?] it by Cycling 74 just to host the downloads; perhaps with the option of re-using code from it themselves [I don't know what deal may have been made] but they never said they were going to maintain it, which is a shame. – Tetsujin Jun 27 '15 at 14:22
1

I don't have a Macbook, so I'm guessing if this will work, based on my Mac Pro, however…

In Audio MIDI Setup [Applications > Utilities]
Audio Devices ( Cmd ⌘ 1 if it doesn't open automatically)
you can set the input & output volume for each individual audio-capable device.

Setting Speaker volume to zero, or checking the Mute box, whilst leaving headphones at standard volume might do what you need.

enter image description here

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .