0

I don't think this option exists, but doesn't hurt to ask. And it would be amazing if Apple could implement this option in case it doesn't exist.

I have people that I correspond that speak different languages. It would simply amazing if my devices and apps (Mail, Messages, Skype, etc) would recognize who I am writing to and remember what autocorrect language I had set up for them.

That way, it would always autocorrect the appropriate language without me having to switch it. (On the actual Mac, switching the languages is not even an easy step).

I hope there is some solution in the meantime other than just turning autocorrect off.. :)

  • I think he's referring to multiple languages that use the same roman alphabet. – William T Froggard Jun 27 '15 at 10:09
1

When editing text, right click and choose "Show Spelling and Grammar":

Show spelling and grammar

Select Automatic by Language:

Automatic by language

This works for me, I use two languages (English and Italian).

Edit: This is for Spelling and Grammar, the setting for autocorrect is in Keyboard->Text: Keyboard->Text

You'll also have to add the languages you will use in the Languge & Region panel of System Preferences.

  • Thanks for your response BrethilI I think that this was the default setting already. Or is there some check-mark that I need to additionally apply to make this work? I have all those fields checked (plus "check grammar with spelling" in your first picture "check grammar" one in your second picture). How does the set-up actually know that you are in fact using Italian vs. English for different people? – user2502562 Jun 27 '15 at 18:45
  • I simply start typing in Italian/English and the words are recognized from both languages, if I'm typing in English and I suddenly start writing Italian words they get marked as wrong/autocorrected to the closest English word. – Brethil Jun 27 '15 at 19:24
  • Ah I see, so mixing languages can confuse the system. As sometimes, a few words do get mixed in. So it is important to keep it at one language at a time. Thanks again for your help! – user2502562 Jun 27 '15 at 19:51
  • I also just realized that it doesn't have autocorrect for some of the languages that I am using, so it is automatically reverting to English? – user2502562 Jun 27 '15 at 20:16
  • I'd add Languages in the Languge & Region panel of System Preferences – Brethil Jun 29 '15 at 2:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .