1

I've had issues where the Wi-Fi seems to slow to a crawl sporadically. This only happens on my home network; I've not seen it happen anywhere else. No other devices are affected while this is happening and I can fix it by restarting the machine.

I know there are issues with Wi-Fi after upgrading to Yosemite, but this was brand new with Yosemite already installed. The Wi-Fi settings were imported through iCloud if that makes any difference.

  • Answering this is pure guess work. Can you provide some data. What are your WiFi settings, values when it works vs when it is slow. It is very simple, just hold the "alt" key and click on the WiFi icon, then note the numbers (or take a screen shot) At the moment it looks random since we have not found the source. – Ruskes Jun 27 '15 at 2:04
  • Same issue with me. Yosemite clean install. The WiFi speed is very very slow. Where Windows PCs get mbps speed, I get just few hundred kbps. Really frustrating. Waiting for 10.10.4 and hoping that the issue has been resolved. – Pratik Jun 27 '15 at 3:06
  • @PratikaRana you can wait or you can share your wifi settings and performance numbers. – Ruskes Jun 27 '15 at 3:32
  • @Buscar웃SD I will wait till 10.10.4 arrives and then I compare with 10.10.3. – Pratik Jun 27 '15 at 7:41
1

Delete your network settings in System Preferences and starting over usually solves this problem. To check, create a new "Location" in System Preferences > Network, and enter your password to connect to your Wi-Fi network.

You can then try deleting the stored Wi-Fi information just for that network by setting "Location:" to "Automatic," clicking Wi-Fi in the left field, clicking "Advanced," and finding your network on that list.

If you see no improvement, continue deleting saved Wi-Fi Preferred Networks until you do. Personally, I would delete all of them, and start fresh.

These seem to get corrupted occasionally when synced by iCloud, in addition to your MacBook Pro attempting to connect to each network in the order they appear in the list if your connection is interrupted.

  • Deleting the network settings seemed to work. – Magnus Jul 8 '15 at 9:48
2

The issues aren't with upgrading to Yosemite, they're with a component of Yosemite - every Yosemite machine runs the risk of having them. The issue's been resolved in the latest version of the OS X 10.10.4 beta, which you can download by joining the Apple beta program and following the instructions to put the beta on your computer.

Here's an article explaining more about the bug in question, if you're interested.

  • Thank you for the informative link, however I feel it's important to note that many of these issues can be overcome by admin changes. – Rampant Jul 20 '15 at 18:23
  • Yeah, there were ways to bring mDNSResponder back in 10.10.<4 if you really wanted to. However, especially now that 10.10.4 is stable, a simple software update sounds like the easiest solution. – user24601 Jul 20 '15 at 18:28
  • @user24601 - I'm having this same issue with 10.10.4. – doublesharp Jul 26 '15 at 22:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .