Some months ago I bought a USB flash drive 16 GB, and I have used it on my Windows machine with no errors or bugs, whatsoever.

Since that I need to move some files from my Mac, the flash drive does not appear to be mounting in OS X at all.

When I run in diskutil list in Terminal, the flash drive does not appear, not even in Disk Utility.

I am starting to think that maybe something is wrong with the stick? However, the strange thing is that it's working just well in Windows. How can that be? Other flash drive (have tried with a 256 MB) works well on the mac, except the 16 GB.

Any suggestions or thoughts?
I am running Mavericks on a MacBook Pro (older one).

  • 1
    Check to make sure the device is being recognised by going to: Apple menu > (hold alt) System Information > USB and look through the list for the stick. Jun 26, 2015 at 20:03
  • 2
    I have questions: Does it show up on other computers? Has it ever worked on this computer? Does it work on any other Mac? Do other devices work in the port? Have you tried rebooting? Have you tried using another port? Is it USB 2 or 3? Jun 26, 2015 at 20:48
  • 1
    Do you know the exact make and model, could you google to see if its just this particular device or the whole product range. Jun 26, 2015 at 21:06
  • 1
    And other USB sticks work fine? Jun 26, 2015 at 21:26
  • 2
    MBR won't affect this issue, it should still show in the System Information tab, and in Disk Utility as a device you can format back. Jun 26, 2015 at 21:37

5 Answers 5


Based on the answers you've given in the comments.

  • The device doesn't show in Disk Utility
  • It doesn't show in System Information under USB
  • It works in other computers
  • Other USB sticks work in this computer – Changing USB ports makes no difference
  • The device is getting warm – It also doesn't work in another OS X system

I would suggest that there is an incompatibility between this USB stick and OS X, it could be there is some kind of damage to the sticks Firmware or a wider issue with the product that you've not been able to trace down other reports of.

Short of opening up USB Prober and understanding more about how USB communications happen, I would suggest the stick is defective and you try to get a replacement from the retailer.

  • 1
    I am sorry if this isn't a solution, but I think we've exhausted all options, there is some kind of conflict between the USB stick and OS X. Jun 26, 2015 at 21:36
  • I think i will leave it with it's a fault of the USB stick. I mean. I bought it for only $15 so i don't want to do a lot of writing to the company in stuff. I think i will buy a better quality drive and hopefully this time it will work :) Thanks for your patience so far :)
    – simond
    Jun 26, 2015 at 22:01

This may be helpful to some people who have simpler versions of this problem. In DISK UTILITY app, change the View Mode of Sidebar from default "Show Only Volumes" to "Show All Devices". Then the formatting options become visible.


In my case I had a brand new Silicon Power 16 GB flash drive pre-formatted as FAT32 which showed up on my Mac Desktop; it showed in the Finder, it showed in the "Get Info" window and verified as FAT32, but it would not show up in Disk Utility sidebar. I wanted to reformat it to Mac OS Extended Journaled but Erase and Mount were greyed out. I checked the System Report, it showed up on USB bus as well.
I finally noticed Disk Utility's sidebar panel had a down-arrow next to the "View option" at the top of the toolbar. Once I clicked the arrow to change views, I saw my USB volume, which then I was able to erase and reformat.

After View is changed to "Show all Devices"

This is only helpful for those having problems Erasing & reformatting in Disk Utility, yet otherwise the flash stick is showing up.

  • 1
    This solved form me!
    – kitsune
    Feb 17, 2019 at 20:34
  • 1
    Wow, you save my days!
    – Andree
    Feb 25, 2021 at 11:13

For my case:

  • The device doesn't show in Disk Utility
  • It does show in System Information under USB
  • It works in other computers
  • Other USB sticks work in this computer
  • Changing USB ports makes no difference

I just rebooted the system, then it's mounted and working correctly.


From this MacWorld article, sometimes a drive can be "connected" and visible in DiskUtility (not Finder), but not mounted. If that's the case, then you may be able to select the volume in DiskUtility and click the Mount button in the top toolbar, in order to successfully connect it systemwide.

It's not clear to me (perhaps someone would comment) if this indicates a problem with the drive, or perhaps even with the computer or port.

Also I should note I experienced this with a hard drive. I am not 100% sure that the same problem and solution apply to flash drives.

  • I had a similar issue after not unmounting an SSD (I just unplugged it), then after a Mount with DiskUtility it finally came back. Mar 3, 2020 at 12:01

Today I bought another USB Flash drive, more specific: SanDisk 16 GB. It works perfect with no errors. So my conclusion is that the other USB that did not work was too cheap and not working.

  • Shame not to get the credit as I sis say you should try to get a replacement... Jun 27, 2015 at 16:48
  • I marked your answer as solution, I see what you mean :)
    – simond
    Jul 6, 2015 at 8:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .