2

I recently installed LibreOffice Vanilla (LOV) from the Mac App Store. I want it to be the default app for opening .csv files.

First, I tried to open a .csv file using the "Open With" dialog. LOV is not an offered option, so I clicked on "Other" and there it is but it is ghosted until I go from "Recommended Applications" to "All Applications".

That should be it, but I then get this error message (I think from "Gatekeeper"):Whiny Message

If I go into Security Preferences I can make it "Open Anyway", but the next time I try to open a .csv file I get the same error.

How do I set up my Mac so double-clicking on a .csv file will have it open in LibreOffice?

Update: I found a procedure (described as an answer below) that will make LibreOffice the default app for ONE .csv file, but I have to go through the same steps (add LibreOffice to "Open With" and tell Gatekeeper to "Open Anyway") for every .csv file that has not had this done.

So how do I set up OS X so that double-clicking on any .csv file will have it open in LibreOffice?

  • See apple.stackexchange.com/questions/107464/… for possible work-around – tubedogg Jun 26 '15 at 19:44
  • Gatekeeper has no bearing on what app is allowed to open what documents. The error message you got is specifically in reference to Gatekeeper believing the app is unidentified. The other work-around is to Option-click on the app and choose Open which should cause Gatekeeper to register it as you wanting the app. (You could also try this on the csv file in question, it may force a Gatekeeper override there too.) – tubedogg Jun 26 '15 at 19:46
9

I had the same problem and finally managed to fix it. Simply adding 'Libreoffice Vanilla' by doing a right click on a csv file and choosing that app did not remember this for all csv files, as you state.

I was able to configure it by going to the info of a single csv file (mac button & i or rightclick and 'Get Info'). Open the 'Open with' apps list and you'll probably need to choose the 'Other' option at the bottom. Choose the 'All Application' selection and 'Always Open With' option while finding the Libreoffice app in the list and confirm that selection.

Now you'll have to click the 'Change all' button right under the App selection combo box on the general file info window. This step ensured all other csv files to open using Libreoffice from then on.

  • Worked perfectly! Surprised it was that complicated, but very good to know. – Fred Hamilton Jul 15 '15 at 16:59
  • I had the same problem, but with Microsoft Office for Mac, which I assumed would play nicely with OSX. – user5920660 May 15 '18 at 22:11
1

Gatekeeper has no bearing on what app is allowed to open what documents. An easy work-around is to Option-click on the app and choose Open which should cause Gatekeeper to register it as you wanting to override it. (You could also try this on the csv file in question, it may force a Gatekeeper override there too.)

1

Update: Added this answer because I thought I'd found the solution (see next paragraph) but it turns out that only fixes it for the ONE .csv file you "train" it with. Still have the same issue when I try to make it open any other .csv file.


OK, I think this was a conflation of several issues. I just downloaded an update to LibreOffice Vanilla where the first fix was "Clicking on files in Finder opens the file in LibreOffice now". So I sorta think that was part of the confusion.

Now that that part of LibreOffice was working, I went through the right-click "Open With" process I described originally followed by the "Open Anyway" in Security Preferences. That seemed to make LibreOffice the default app for .csv. Then I double-clicked on a .csv file and got the same error message, so I repeated the "Open Anyway" in Security Preferences.

That seems to have done the trick: double-clicking on .csv files makes them open in LibreOffice without any issues now.

0

You could try setting LibreOffice as the default application.

  1. Under the Apple Menu select System Preferences...
  2. Select Default Apps
  3. Locate CSV in the list
  4. In the drop-down set the default application to LibreOffice. If it is not listed in the drop-down list select Other... from the list and locate it in Applications.

Default Apps

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .