MacBook Pro Retinas dropped the line-in (microphone) jack that previous MacBook Pros had. Sometimes I want to plug in a 1/8" microphone, but there's no option to switch the input from "internal microphone" to "line in".

Sound Preference Pane

Is there a way through the command line or 3rd party utility to reverse the direction of the headphone jack to use it as a line in for a microphone?

  • That would not work. Line in requires that the microphone has a power source. Headset do not.
    – Ruskes
    Jun 26, 2015 at 0:04
  • 1
    @Buscar웃, you only need phantom power if trying to connected directly to a condenser microphone. Line input and dynamic mikes don't require power.
    – Joshua
    Mar 10, 2016 at 21:31
  • 5
    This question has some pretty thorough responses to the same problem: apple.stackexchange.com/questions/90344/… Oct 6, 2016 at 14:28

1 Answer 1


For those Macs with a single shared input/output jack, the key to using a microphone is to have the correct plug. I'm guessing your're not seeing the input options because your microphone jack doesn't have three rings on it (Apple headsets with microphone have three rings)? If that's the case, you'll need to get a splitter cable so that the Mac realises that a microphone is available. See here for more information.

  • 16
    I am using a TRRS plug (4 poles, standard CTIA) and the microphone isn't working. Sound settings do not allow the option to use the 3.5 port for audio input. When plugging the same thing into a phone, everything works just fine. So, I have to assume Apple just didn't bother to wire it properly.
    – Asu
    Jan 16, 2019 at 17:34
  • 15 inch MBP from 2015 here. I just plugged a headphone set with an inline mic into the 3.5mm jack and it worked. So I have to assume that Apple wired it properly.
    – Luke Worth
    Feb 24, 2020 at 7:16
  • 1
    @LukeWorth I think there might be some implementation details that I’m not aware. I tried plugging in a headphone-with-mic (QC20i) into the jack, and it can record audio from the mic; in “System Preferences -> Sound -> Input” it recognizes the microphone as “Audio line-in port” instead of “Built-in”. In contrast, when I plugged a TRRS splitter, the name didn’t change from “Built-in”, namely the OS didn’t recognize that there is audio signal from the port. Jan 22, 2021 at 8:26
  • I’m using an iMac. My guess is that there is some “handshake” between the headphone-with-mic and my iMac; the headphone probably comes with a chip in it doing the handshake, while the splitter doesn’t have such functionality. Actually, on the description page of the splitter I bought, it says “not support iMac”, but I missed it when placing the order. Jan 22, 2021 at 8:56
  • 1
    @Asu I think an external sound card connected with USB is your best bet. It can be as small as an adapter, about $15. Jan 22, 2021 at 9:03

Not the answer you're looking for? Browse other questions tagged .