I received my 38mm Apple Watch Sport only a little under a month ago. So far, I love it. It works great... usually. Plenty of people online have complained about slow load times when opening apps, especially 3rd party ones. But for me, they rarely open at all. I'll wait for minutes, long enough for the device to lock, and still nothing. The only solution now is to restart (usually a forced restart by holding down both buttons on each device) both devices and try again. It's getting to the point where it's pretty frustrating to have to restart at least twice or thrice daily, especially since when I enter my password (it's text) on my iPhone, it freezes for 3-5 minutes and then restarts and lets me use Touch ID. Restarting sometimes doesn't solve the problem anyhow.

Anyone else having this issue? It's been happening now for a few weeks.

Some stats:

  • My watch arrived on June 1, 2015
  • My watch has 82 applications, 100 photos, and no songs
  • My watch is running watchOS 1.0.1
  • My watch has 5.6 GB of space available
  • My phone is an iPhone 5s 64 GB running iOS 8.3
  • My phone has 238 MB left (but that fluctuates frequently; could this be a source of the issue?)
  • My phone often has problems staying on wifi and likes to drift off onto 4G whenever it feels like it (sporadically, and not super often, but I felt this was mention-worthy)
  • My phone is around 2 years old now

Thanks in advance.

Update: I've realized that restarting my Apple Watch might be enough to temporarily solve the problem, and the issue only seems to come up after I install a new app on it. Another thing to keep in mind is that the Apple Watch app on my iPhone is faulty, and often crashes or does not work properly.

Update 2: Now I think I can positively state that there is no pattern to my Apple Watch functioning or not. I've just proven the previous update wrong, then. I wish this issue had some predictability.

Update 3: My watch has been pretty good all of today (June 29, 2015), but just started acting up again. Here are a few things I noted that may prove useful:

  • The watch responded perfectly for at least 3 hours straight, during which I was able to use it to read books, search the web, and add cards to Trello lists.
  • I attempted to load Trello an hour later. The app loaded, but after loading, it showed the circular loading icon on the home screen without any of the icons showing.
  • I did some testing:
    • I let Trello run, and it crashed.
    • I opened it again. I timed 32 or so seconds before it crashed again, staying on the loading screen this time.
    • I restarted the watch normally, and tried again, but it didn't load.
    • I then force restarted the watch, letting it sit on my wrist for a few minutes after starting up. It didn't ask for my password.
    • I immediately went to the Trello app. After maybe 5 seconds (I didn't time this one), it loaded perfectly.

I'm baffled by the apparent lack of a pattern here.

Update 4: This is starting to feel like a journal. There truly is no pattern. All day (June 30, 2015) I have been restarting both my iPhone and Apple Watch, with the watch working for only 10 or so minutes at a time. I can't get any apps to load consistently.

If I discover any other clues, I'll post another update.

  • I'm having the same issues. I can't get either of the third party apps to load at all (Lutron, Roomie). So far, nothing has worked (re-installing, rebooting phone/watch,...) – user134877 Jul 4 '15 at 16:19
  • @Mark What's interesting to me in my case is that it works on and off. For example, this morning I used Spark on my watch just fine, but now, I can't load Trello and am restarting once more. Is it the same for you, or can you not load them ever? Anything else you've noticed? – jmindel Jul 4 '15 at 20:52
  • @Mark I think I discovered something that may help: (1) letting the apps crash multiple times after restarting and waiting around a minute each time until they load, and (2) force quitting troublesome apps (found out how online) by holding the power button until the shutdown menu comes up, then releasing, and then holding it again until the home screen shows up. Still doesn't fix the problem, though. – jmindel Jul 4 '15 at 23:18

Not sure if you're still having this issue and this is also for future users who have the same problem as well. A lot of people experience the app not loading problem.

The solution to this is fairly easy. All you have to do is restart your Apple Watch. You can do so by pressing on the side buttons (Digital Crown and the button below it) at once. Just wait for it to restart. If it doesn't help, reset it into factory settings.

Source: Cupertino Watch

  • Thanks for the response. At this point, the problems are mostly gone. I don't think I've had any or many issues for maybe a year now, given the timestamps. Restarting the way you suggest never did work. That's one solution I tried many times, but never had any luck. I mentioned this in another comment, but for future users, as you said, I would suggest force quitting troublesome apps or upgrading to a newer OS. I think that fixed the problem for me. – jmindel Apr 1 '16 at 8:45
  • Glad that you no longer have the problem. Thanks for the input. – Hawon Nguyen Apr 2 '16 at 20:40

protected by Community Nov 20 '15 at 4:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.