0

Earlier today, I decided to clean up my hard drive of extraneous files and other materials that might be taking up space. After doing some looking around, I found an application, OnyX, that was recommended for what I was aiming to do. After starting OnyX and it doing a check of the HD, it said I needed to reboot my computer using ⌘ + R and run Disk Utility to repair the disk. After running Repair Disk on the Mac HD, I got these errors:

Incorrect number of file hard links
Invalid directory item count
Orphaned file inode (id = 515789120)
The volume Macintosh HD could not be repaired

Most ominous, however, was the last error message presented:

Error: Disk Utility can't repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

Trying to avoid what would be the worst case scenario, I quit Disk Utility, restarted the computer, and looked for answers. After finding some solutions, I tried once again to boot my computer with ⌘ + R. I ran Verify Disk as well as Verify Disk Permissions a few times, each time getting the message:

This volume Macintosh HD appears to be OK.

I restarted again, this time not rebooting with ⌘ + R, and ran Disk Utility normally just to be sure, after I found and read this question. Unlike the question asker in that thread, however, I didn't face any more errors after running Disk Utility again. Multiple verifications have shown that the disk is fine and does not need to be repaired, but this leaves me puzzled.

Is my hard drive actually functioning fine and I don't need to worry about any irrevocable errors, or is the underlying problem still there and I need to fix it before it worsens?

  • Odd... If I had to guess, this may have been the result of some incomplete file operation, which completed shortly after your initial verify was done. Disk access is blocked during a verify. It would have to be incredibly well-timed, but that's my only theory. – William T Froggard Jun 23 '15 at 6:31
  • @Froggard I suppose that's possible, and as good as any theory I can think of at the moment. I'll probably do some further digging around and see if any changes come up. – Shmoo Jun 23 '15 at 6:40
0

I have found that when Disk Utility can't repair a disk then it is time for DiskWarrior or another third-party disk repair utility. They can often fix what Disk Utility can not.

However that the issue went away, seemingly by magic, makes Froggard's guess probable.

I would, however, keep an eye on the disk with disk utility. Use the verify function from time to time and if it does not return then it was indeed a transient error that the O/S was able to repair itself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .