5

Firstly I would like to say that I have never used a Mac in my life before today so apologies if i am a little slow on the uptake. I recently purchased the iMac (27-inch, Mid 2011) which i believe is running a Yosemite v10.10 OS.

The iMac was second hand and there was no install discs in the box. It did come with the Apple mouse and keyboard, however i cannot pair them with the Mac as the Bluetooth won't turn on ('Turn Bluetooth On' button is greyed out in System Preferences>Network>Set Up Bluetooth Device...). The Bluetooth icon in the top left is also greyed out with a line through it and says 'Bluetooth: Not Available' on it.

So far i have Deep Breath:

  • Checked the technical specs to ensure this model has Bluetooth.
  • Repaired Disk Permissions in Applicatiopns>Utilities>Disk Utilities + Restarted.
  • Deleted 'com.apple.Bluetooth.plist' in Library>Preferences + Restarted
  • Reset the SMC + Restarted
  • Completed a PRAM reset + Rebooted
  • Installed the 'Bluetooth Switch' widget (Which appears to do nothing)
  • Some people have suggested that if you shut down and log in a few times it eventually sorts itself out, well i have done that about 10 times now and it has definitely not fixed itself.

... and none of it has made a single bit of difference.

Not such a good start so far from Apple, I am starting to wonder why i switched from PC's. Can anyone help to restore my faith?

  • I had a similar problem; had to reinstall to solve it. Did the person who sold you the iMac reinstalled or just deleted his user? Have you tried Apple Hardware Test (support.apple.com/en-gb/HT201257)? – Jaime Santa Cruz Jun 22 '15 at 19:42
  • thanks for the suggestion. I have now tried the hardware diagnostics test, however the short and full tests both cam back clear so no issue with the hardware. I bought it from an auction site that specialise in liquidation stock and repossessions e.t.c so have no idea who previously owned it. I would assume it would be illegal to sell somebody's computer against there will without first wiping it as it may contain personal details. However I can't be sure. The fact that the Yosemite OS is on a 2011 Mac suggests to me that this OS wasn't the original so i would guess it has had the OS reinstall – Dan V Jun 24 '15 at 21:16
2

Try resetting the NVRAM. After all else failed this worked for me.

https://support.apple.com/kb/HT204063

Option key + Command key + P key + R key

Shut down your Mac, then turn it on and immediately press and hold these four keys together: Option, Command, P, and R. You can release the keys after about 20 seconds, during which your Mac might appear to restart.

When your Mac finishes starting up, you might want to open System Preferences and adjust any settings that were reset, such as sound volume, display resolution, startup disk selection, or time zone.

Not the answer you're looking for? Browse other questions tagged .