0

So I've configured my mail using a profile. I have setup 3 mail accounts, but each time I launch Mail, it asks me for the passwords of all those accounts. The first time I thought: maybe that's a bug in Mail when mail accounts are configured using profiles. Unfortunately, that doesn't seem to be the case: it prompts me to enter the password for all 3 accounts, and it doesn't stop. When I enter it, it just asks me for the passwords of the other accounts, and then it asks for the first one again, etc., etc.

When I go to the Preferences, I can see that the passwords are indeed not entered. It can only connect to one(!) SMTP server (that's what Connection Doctor says).

What is causing this and how can it be solved?

  • First of all: simplify your problem. Make one account work correctly. Then inactivate it, and add the second one. – dan Feb 3 '16 at 17:46
1

The quickest way to run through the potential problems is to follow these steps:

  1. Check the keychain to find any entries that match your email accounts, then delete all of them. Reboot.
  2. Try to connect again, entering your passwords again. Check email again and see if the error reoccurs.
  3. If the error happens again, delete your email accounts using the system preferences, reboot, and then add them back. Check email again.

If the error continues to occur after doing all that, you might think about taking your Mac into the Apple genius bar.

0

Your Mail accounts are saved in your keychain.

Take a look if they are there (with password ect..), you might see multiple entry (2) for each account. One is for sending (IMAP) one is for receiving (SMTP)

If you have problems try restoring the Disk permissions in the Disk utility.

  • IMAP is for receiving, and SMTP for sending. – dan Feb 3 '16 at 17:43
0

Check that everything is typed in correctly. In my case, my employer reset my account and somehow a space got inserted into the email address before the '@'. It was impossible to see on the accounts pop-up, but when I checked the keychain it appeared as a full tab - e.g. "name.name @employer.com".

Deleting the passwords in keychain and removing the space worked. Thanks -- the IT team at my company couldn't figure this one out!

-1
  1. Sign in in your gmail account from your browser.
  2. Go to https://www.google.com/settings/security/lesssecureapps
  3. "Turn On"
  • 1
    ow does that deal with multiple accounts - and the question does not say googlemail – Mark Nov 21 '15 at 8:10
  • This is not a Gmail account. – William Edwards Nov 21 '15 at 8:55
  • This is a random answer fallen from Google by accident :(. – dan Feb 3 '16 at 17:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .