1

So I downloaded this application that I am relatively sure is able to run fine on 10.7.5 (My version of OSX), but when I try to open it, a message pops up saying that it requires at least version 10.8.5. The reason I think it should work with my OS is because an older version of the app does, and as far as I can tell, there is no real content added between that update and this one, so I don't feel they could have refactored it so much in a somewhat insignificant update that it no longer works on my OS. (And this application really doesn't let you downgrade, so done say I should do that) It doesn't open and then crash. When I try to open it, just a window with the Finder icon pops up saying that it doesn't work on the current version of my OS, and I need 10.8.5. The application doesn't even try to open. So I feel that there must be a flag somewhere in the code or something dictating minimum version required. So my question is: Is there a way to ignore this flag and open this application regardless of minimum required version?

  • Why don't you download the older version of the app then? – nelson2tm Jun 21 '15 at 14:04
  • Any reason why you can't upgrade to OS X 10.8.5? – user24601 Jun 21 '15 at 14:09
  • Ok. I said that you can't get the older version of the app. They force you to update it, and they don't really let you downgrade. And also OS X costs $20, and I paid the shown price for the app, so I shouldn't have to pay more. – RothX Jun 21 '15 at 14:12
  • @RothX Yosemite (OS X 10.10) is free. – user24601 Jun 21 '15 at 16:06
2

That check is done by checking the application's plist.

  1. Right click on the application and click "Show Package Contents"

  2. Open "Contents"

  3. Open "Info.plist"

  4. Scroll down to where it says "LSMinimumSystemVersion" or "Minimum system version" depending on the editor you're using.

  5. Replace the string on the next line which should be "10.8.5" (or to the right of the key, again, depending on the editor) with "10.7.5". Try to open the app again.

  • 1
    You may have to restart to get it to actually check the plist again though – William T Froggard Jun 21 '15 at 14:10
  • So I tried this. It still didn't work, it came up with the same message. I searched for apps ignoring plist minimum version, and it said I had to use the touch command in Terminal. I did this and it sort of worked. WHen I tried to open the app, it didn't open, it just said that it quit unexpectedly. I'm guessing this means that they hardcoded the minimum version in. Oh well. Thanks for your help anyway. – RothX Jun 21 '15 at 14:14
  • 1
    It's possible they're using 10.8-only code, even if they're not using any user features from 10.8. That could be the reason. – William T Froggard Jun 21 '15 at 14:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .