8

I'm running Linux in a VM on my VMWare Fusion. I want to use qemu-kvm within the Linux VM (yes, I know it's not efficient).

QEMU reports the following problem:

Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
11

Stop the virtual machine and open its settings. Under the "Processors & Memory" pane, expand the "Advanced options" section. Check "Enable hypervisor applications in this virtual machine."

You can also manually edit the VM's .vmx file. For example, if your VM is named "Ubuntu", edit Ubuntu.vmwarevm/Ubuntu.vmx (to get into the .vmwarevm in Finder, select Show Package Contents).

Within the .vmx file, add the following line:

vhv.enable = "TRUE"

After doing either of the above, restart the VM and you can use KVM.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .