13

Problem : I left the MacBook to be idle for a while and its keyboard and trackpad became non-responsive. I shut it down and restart 3 times (using the power button), and the MacBook now goes to a strange start up screen.

I tried all boot options, but the key combinations doesn't work. The only thing I can do:

  • Turn off (Use power button).

  • Turn on (Use power button), it starts and go to the screen.

Detail boot progress:

  1. Press and release power button

  2. Apple logo and progress bar displays (As soon as I press power button from turn-off state).

  3. The progress bar runs and the screen shows up with the pointer in top-left conner of its screen.

  4. I can't do any thing except turning off the Macbook. Below is the screen caputured images.

Also, the video show full start-up progress: https://www.youtube.com/watch?v=xRy8QgdBj_E

MacBook spec:

MacBook Air 11.6 early 2014
1.7GHz Intel Core i7 Dual-Core (Haswell)
8GB of 1600 MHz LPDDR3 RAM
128GB Flash Storage
Integrated Intel HD Graphics 5000
11.6" LED-Backlit Glossy Display
1366 x 768 Native Resolution
802.11ac Wi-Fi, Bluetooth 4.0
Dual USB 3.0 Ports, One Thunderbolt Port
720p FaceTime HD Camera
Includes Mac OS X 10.10 or OS X 10.9 Update

The MacBook is silent as I minimized sound volume before it's failed to boot. I can't reset PRAM (Command, Option, P and R) but it's possible to reset SMC. The keyboard and trackpad appears not to be responsive. At the present, The Mac is running OSX 10.10.3 .


Updates:

@Buscar: There's no external devices that connect to the Mac. I've just created a USB tick using Transmac app, but the Mac doesn't start from the USB tick.

I've ever tried all boot options using key combinations as Apple's guides but the boot options are not able for the Mac as the built in keyboard is not recognized.

I created the USB tick from this guide : Create Bootable USB Drive Yosemite Mac 10.10 With TransMac (Intel & AMD).

@ Typerix,

I've never used Magic Mouse, Magic Trackpad Or any external devices before.I bought the Mac one year ago (In US) , It is a MacBook Air 11.6 Early 2014 as the retailer mentioned in the order. Unfortunately, There's no Apple AS or retailer.

I will buy or borrow a USB mouse from my friend to give it a try as your advice. Btw, I can't book to Recovery or from a USB tick.

@Bob : Should I use an external keyboard to try to fix the issue?

@bmike : I will try your advices to see whether an USB mouse works. thanks.

Latest updates:

I used a Magic Mouse and Apple wireless keyboard, now, I can boot to OSX as normal. The internal keyboard and trackpad hasn't still not worked. Hope it is not a hardware issue.


06/22/2015

With a Magic Mouse and Keyboard, I can boot the Mac using all start-up options as well as reset NRAM(PRAM) mentioned in Apple KB. I can reset SMC using built-in key board and MagSafe power adaptor. It doesn't not require an external key board.

See the logs or run Apple Diagnostics(boot while holding down D key using an External Keyboard). I see the log as the following error:

Jun 22, 2015, 11:47:23 PM kernel[0]: Error: AppleHSSPIController::doSPITransfer NAK received from device
Jun 22, 2015, 11:47:23 PM kernel[0]: Error: AppleHSSPIController::doSPITransfer CRC from device was invalid: computed 0x30FF, received 0xFFFF

The recent attempt, I deselected "Put the computer’s hard disk to sleep whenever it’s inactive" both 2 tab in energy saver (system preferences). Then let the Mac to be sleep for a hour. When I restart the Mac again, the built-in keyboard black lights turn on.However, the built-in keyboard and track pad is not responsive. The Mac tried to detect a Bluetooth keyboard. Now, the Bluetooth keyboard is failed to pair with the Mac. Magic Mouse is not able to use too.

Try to pair the Bluetooth keyboard more than 20 times. Then, it is able to use the external keyboard and mouse again.


Look like it is not a hardware issue. Below is NRAM contents I got from logs (Sys Info) :

Source: /usr/sbin/nvram -xp
  Size: 2 KB (1,596 bytes)
  Last Modified:    6/23/15, 11:23 PM
  Recent Contents:  <?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>ALS_Data</key>
    <data>
    AQE=
    </data>
    <key>LocationServicesEnabled</key>
    <data>
    AQ==
    </data>
    <key>SystemAudioVolume</key>
    <data>
    XQ==
    </data>
    <key>SystemAudioVolumeDB</key>
    <data>
    AA==
    </data>
    <key>Test_ALS_Data</key>
    <data>
    AQA=
    </data>
    <key>aht-results</key>
    <data>
    PGRpY3Q+PGtleT5fbmFtZTwva2V5PjxzdHJpbmc+c3BkaWFnc19haHRfdmFsdWU8L3N0
    cmluZz48a2V5PnNwZGlhZ3NfbGFzdF9ydW5fa2V5PC9rZXk+PGRhdGU+MjAxNS0wNi0y
    MlQxOToxMzoyNVo8L2RhdGU+PGtleT5zcGRpYWdzX3ZlcnNpb25fa2V5PC9rZXk+PHN0
    cmluZz4xLjAuNjwvc3RyaW5nPjxrZXk+c3BkaWFnc19yZWZlcmVuY2VfY29kZV9rZXk8
    L2tleT48c3RyaW5nPlBQUDAwNyxORFIwMDEsTkRLMDAxPC9zdHJpbmc+PC9kaWN0Pg==
    </data>
    <key>backlight-level</key>
    <data>
    AgQ=
    </data>
    <key>bluetoothActiveControllerInfo</key>
    <data>
    j4KsBQIAAAAzFGR2urF6dw==
    </data>
    <key>bluetoothInternalControllerInfo</key>
    <data>
    j4KsBQAAMxRkdrqxenc=
    </data>
    <key>boot-gamma</key>
    <data>
    EAYAAPOcAAAAAAAAwgAAAAAAAAAPAAILsQcFFhkSCyyoKY01MTZPPB0+VFNyVF54ZXqh
    h26KZZVbmq20mbvww0LJ9NHV0v337fD++zD2//1U+gsAAgpcBgUUzA5KKLQiTzx8ORhg
    jFpeeDJyoYe/gbDAP7/22UfW/PDf7P758PYQAEIJgAQEE8UKSy7/IQ8/Ay9ffwBeqKFc
    ebDBuZbzzlCkuOEOubvsOcf99sXV/vmx2/77teH//N/l//1s6//+LPM=
    </data>
    <key>fmm-computer-name</key>
    <data>
    VmluaOKAmXMgTWFjQm9vayBBaXI=
    </data>
</dict>
</plist>

June 25, 2015 :

As I can use power button, reset SMC and the internal keyboard backlight is working, I tried to re-install OS X in recovery mode using a Magic Mouse and Bluetouch keyboard as the last try for firmware/software impacts. However, the issue is till not resolved.

  • Your mouse and keyboard aren't recognized anymore. – Rob Jun 20 '15 at 16:34
  • This is only tangentially related, but I've never seen a progress bar when booting up before -- why does that happen? – 1110101001 Jun 21 '15 at 2:10
  • @1110101001 It's new in Yosemite. – NobodyNada Jun 21 '15 at 4:06
5

Since the MacBook Air has a mouse and keyboard connected, something went really wrong with the hardware. You could reset the NVRAM and SMC, but it likely needs hardware diagnostics.

  • You might be lucky if you can connect a USB mouse and see if at least the cursor works.
  • Also, boot holding Command R to enter recovery mode.

It's a long shot that the above things will get you further, but they are quick and easy to try before you use https://locate.apple.com to find a service tech or call AppleCare for further diagnostics.

  • In recent day, internal keyboard backlight turns on when the Mac boots to OSX login screen. Using a Magic Mouse and Bluetooth keyboard I can use the Mac as normal and I'm able to boot to recovery mode. I've not reinstalled OS X yet. I will try to reinstall the OS as the last try before using a service test or go to a Apple AS at this weekend. – rgOne Jun 25 '15 at 5:45
  • Without an external keyboard and Magic Mouse. I can do only the following : power button, reset SMC ( power button+shift+control+option and MagSafe power adapter), boot to login screen. The keyboard black lights turn on. – rgOne Jun 25 '15 at 5:52
11

The graphics are telling you to turn on the Magic Mouse or Magic Trackpad associated with the MacBook. Have you ever connected one of these devices to it?

If you haven't, I have to wonder if the internal keyboard and trackpad are not connected somehow. What year is this MacBook? Is it still under warranty?

Unless you can boot to recovery and reinstall OS X, your best bet is likely taking it to an Apple Store. If it's a hardware problem, it is better to let them deal with it.

EDIT: Now that I think about it, both pictures are pointing devices, and you say the trackpad doesn't work. Do you have a USB mouse you could try plugging in? It may be that the trackpad is broken, so OS X is asking you to provide a pointing device.

  • The mouse is not recognized indeed. – Rob Jun 20 '15 at 16:35
  • I've not got the chance to use any external devices such as Magic Mouse, Bluetooth keyboard and USB keyboard with the Mac before. I will reinstall the OS X to see whether it works before using Apple AS. Look like the Mac is not under warranty as I can't get any information from Apple service plan official page. – rgOne Jun 25 '15 at 6:00

protected by Community Jun 21 '15 at 9:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.