3

I’m running iOS 8.3 (12F70) on an iPhone 5S. This is an off-the-shelf device that has only ever been used with public releases; there’s never been any mucking around with developer betas or similar. But I have a bug that was giving me real headaches.

If I launch Safari, and start typing into the search/URL field, the app crashes within about four characters, and dumps me back to the home screen.

I’ve tried many different things to try to cure this:

  • Kill Safari from the app switcher
  • Reboot my iPhone (both normal and a hard reset)
  • Change all my settings related to autofill, default search engine, etc. back to the defaults
  • Disable all the iCloud-related Safari features, and delete my iCloud data from the device
  • Look for crash logs on the device by hooking up to my Mac, and using Xcode. No joy.
  • Clear Safari’s website data.
  • Freeing space on the device (I was running quite low)

But whatever I do, Safari still crashes. This issue has been plaguing me for a week, and I can’t find anybody else on Google who’s having the same problem.

What should I do?

  • Have you tried clearing safari history and website data. Go to settings --> safari --> clear history – vembutech Jun 22 '15 at 14:23
  • Given the sudden spike in traffic, I assume this question just got linked from somewhere -- but where? – alexwlchan Jan 27 '16 at 10:17
1

Deleting my history fixed it for me.

Safari > Bookmarks icon > History tab > Clear

Something in my history was poisoning the search results, and causing Safari to choke whenever you trying to type something into the search field. Since Safari tries to suggest pages that you’ve visited before, if a bad site shows up there, it can (presumably) cause things to go wrong.


In my case, the problem site was particularly bizarre. I dumped a copy of my Safari History using iExplorer before I wiped it, and started looking for unusual entries. These two stood out to me:

Title                 URL                      Visits  Last Visited
Cannot Open Page      <long Facebook url>      -7      14 Aug 2015, 17:16
Cannot Open Page      <long Facebook url>      1       14 Aug 2015, 17:12

The Facebook URL is an authentication page that was apparently launched by an iOS game. I don’t understand how it can be last visited in the future (that date is nearly two months after the problem started) or have negative visits.

I’m genuinely mystified as to how that item entered my history – I barely play the game in question, and I’ve never messed about with the date/time settings on my phone. And I have no idea how you get negative visits – possibly some sort of overflow somewhere?

I think it’s likely that this item was the culprit, but how and why are total mysteries.

1

Narrowed it down to Safari Suggestions. I shut suggestions off and it works fine now.

  • 1
    This problem is also on the iMac - so probably everywhere. Stopping the suggestions worked but clearing the history did not. Wish I'd tried stopping the suggestions first :-( . Thanks. – Tim Jan 27 '16 at 9:58
1

I started having this issue tonight and immediately cleared my website data, restarted iPhone, and killed safari from the home screen with no luck.

I finally turned off the search engine suggestions, Safari suggestions, and preload top hit and that seemed to fix it.

I am, by no means, a tech guru so I have absolutely no explanation for why this happened or why turning those things off fixed it. Good luck to everyone else!

0

This happened to me on iOS 9.2 (mini iPad)

  1. Go to 'Settings', turn off 'Safari Suggestions'
  2. Turn on 'Private Browsing'

Both of these worked for me.

0

On iOS 8.4.1 on an iPad gen 3, turning off "Spotlight Suggestions" in Safari settings resolved the issue.

I also cleared all history but that had no impact until I disabled Spotlight.

0

Turn off Search Engine Suggestions and Preload Top Hit. I can confirm normal Safari is working fine now.

My iPad Retina was just doing the same thing. It worked fine an hour ago and then Safari started crashing and closing. It's worth mentioning that Private Browsing was unaffected and worked fine.

I tried deleting history but it made no difference.

You must log in to answer this question.

protected by Community Jan 27 '16 at 9:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .