1

I have a strange problem with my iMac (mid. 2011 21,5) - I can't connect to the network using Ethernet because OS X tells me that it's disconnected when it's plugged in. Sometimes it can see the connection, but the Internet won't work.

Now, I also have this problem with Wi-Fi, it connects to a network but after random time Internet connection stops working. All other computers and phones are working with Ethernet and Wi-Fi; only the iMac isn't.

I tried to do all tests and resets but nothing, today I formatted it returning from Yosemite to Snow Leopard but the problem is still there. Any solution?

network

  • If the problem persists on Snow Leopard it may be a hardware problem. – Jaime Santa Cruz Jun 19 '15 at 20:31
  • I hope no, but I think so, because now after formatting OS X can't connect through Ethernet anyway. – RyanJ Jun 20 '15 at 20:46
  • I also have Imac mid 2011. I experience the exact same frustrating issues. I am running Yosemite as well however just to point out the issue for me began before the Yosemite upgrade. I have just chosen to ignore it and make do. I had never used the ehternet port until I tried to hardwire it well before I upgraded to Yosemite. – user197080 Aug 13 '16 at 13:57
  • Sure sounds like hardware failure if Ethernet shows not connected. The driver has nothing to do with OS X versions and the connection happens when power is applied way before the OS even starts. – bmike Aug 13 '16 at 15:06
2

Just for grins and giggles...

Did you verify that your cable and network port are good?

First thing to try is moving your connection from whatever port on the switch it is on to another. Sometimes a port on the switch just may be bad.

You will also want to verify the cable. If you have access to another computer or a laptop, remove the patch cable from your iMac and plug it into the laptop. If the problem persists, then you will need to solve that issue before doing more diagnostics on your iMac.

Once you have verified that the connection from the switch to your iMac is good, then I would proceed with diagnosing the hardware, then the software on the iMac.

  • I agree. The Ethernet connection happens with the power being applied. Doesn't matter if you run Bootcamp and Windows, Linux, or any version of OS X. No connection is a hardware or cabling or switch issue. – bmike Aug 13 '16 at 15:07
0

Open the Network Diagnostics app located in the /System/Library/CoreServices.

Then Run it to check your Ethernet settings, and/or recommend solutions.

network

To be able to run the test, you need to have the Ethernet connection set up in your Network-Location screen. If it is not there set it up using the (+). Newer mind me calling it Comcast, you can choose the name for the Location.

ethernet

Then also try the different choice:

network

Also disable the WiFi then try the ethernet.

  • I've tried the Network Diagnostics but it tells that it can't resolve the problem, maybe because it can't find any network through Ethernet connection. – RyanJ Jun 20 '15 at 20:42
  • OK, show us your syst pref Network - where it shows all your connections set up (as a screen shot) please – Ruskes Jun 20 '15 at 21:17
  • Sorry for the delay, here my connection configuration: cdn.img42.com/909a81de97b71f859b2f4da027edf4f4.jpeg – RyanJ Jun 24 '15 at 15:30
  • Did you try different protocols (Change the Configura IPv4 ...... to other protocols beside DHCP). In my case it is "PPP", but you can try the any other. – Ruskes Jun 24 '15 at 15:44
  • I tried but no success, I think that the network card is damaged, it's possible repair it or is integrated with the rest (in iMac)? – RyanJ Jun 29 '15 at 19:47
-1

in Yosemite you can choose Network Diagnostics by clicking the WiFi icon in the menubar while holding the Alt(option) key. It is the third entry. In Snow Leopard the Network Diagnostics is in the Utilities folder as far as I remember. Lex

  • I've tried Network Diagnostics in Yosemite and in Snow Leopard (10.6.8) but it can't resolve the problem because it can't find the Ethernet connection, for the WiFi when works it tell that all is fine (and it's true) when not works it tell to restart router. – RyanJ Jun 20 '15 at 20:44
-3

Reinstalling OS X fixed the problem for me (using El Capitan).

You must log in to answer this question.

protected by bmike Aug 13 '16 at 15:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .