17

It seems like I should be able to install inkscape with something like

brew install inkscape

based on what I've seen online. Unfortunately, when I try this I get

Error: No available formula for inkscape 
Searching formulae...
Searching taps...

What am I doing wrong?

14

Update 2017:

The preferred method to install Inkscape with homebrew in 2017 is:

brew update
brew cask install xquartz
brew cask install inkscape

Previous Answer:

Inkscape is a cask that you need to tap first before installing.

I tried a few of the suggestions given on this page, and the only thing that worked for me is a minor variation to jherran's answer:

$ brew search inkscape
$ brew tap homebrew/gui
$ brew install inkscape

At that point, I got the response Installing inkscape from homebrew/homebrew-x11 and the installation completed successfully. The result from the brew search command has changed a few times so be on the guard for it to change again and just tap the correct reply from the search command if it's not homebrew/gui next time you search.

  • 2
    While following these instructions today (with Homebrew 0.9.9 and OSX 10.10) the result of brew search inkscape was homebrew/gui/inkscape. Running brew tap homebrew/gui and brew install inkscape works as before. – Pathogen Apr 4 '16 at 16:50
  • @Pathogen You're right. I had to install Inkscape again a few weeks ago and my own answer no longer worked for me. I've been meaning to update it. I'll get to it soon. Thanks! – Nocturno Apr 4 '16 at 20:29
  • With the current homebrew version tapping is no longer needed for inkscape. brew cask install inkscape does the job (assuming you had previously installed xquartz) – ccpizza Jun 26 '16 at 23:58
  • 1
    brew cask install inkscape installs a distinct package from brew install inkscape See my answer: apple.stackexchange.com/a/234223/106609 – StevenClontz Jul 5 '16 at 20:07
3

Had the pleasure of attempting this on a fresh install of El Capitan this morning. I wanted both the GUI and command line interface. Unfortunately, it seems that the sanest solution was to install two versions, one from brew (for CLI) and the other from brew-cask (for GUI).

$ brew search inkscape
homebrew/gui/inkscape
Caskroom/cask/inkscape

$ brew cask install xquartz # required for GUI

$ brew cask install inkscape # for GUI

$ brew install homebrew/gui/inkscape # for CLI (yep)
==> Installing inkscape from homebrew/gui
==> Downloading https://homebrew.bintray.com/bottles-gui/
==> Pouring inkscape-0.91_3.el_capitan.bottle.tar.gz
Error: The `brew link` step did not complete successfully
The formula built, but is not symlinked into /usr/local
Could not symlink bin/inkscape
Target /usr/local/bin/inkscape
already exists. You may want to remove it:
  rm '/usr/local/bin/inkscape'
To force the link and overwrite all conflicting files:
  brew link --overwrite inkscape

$ brew link --overwrite inkscape # to get the CLI inkscape on your path rather than the brew-cask GUI

The problem with using the Cask version of Inkscape is that it doesn't handle relative paths very nicely, and apparently using it as a CLI isn't recommended. But I was unable to get the vanilla Homebrew version of Inkscape working as a GUI.

  • Well done - chasing which cask and dependency is needed has changed quite a lot over the years for this package. Thanks for the great update. – bmike Apr 8 '16 at 15:28
2

Try this way:

$ brew search inkscape
homebrew/x11/inkscape
$ brew tap homebrew/x11/inkscape
$ brew install inkscape
  • 1
    I get homebrew/x11/inkscape Caskroom/cask/inkscape from brew search inkscape, but when I try brew tap for both homebrew/x11/inkscape and Caskroom/cask/inkscape I get Error: Invalid tap name – Shep Jun 19 '15 at 6:56
  • 1
    If you have brew cask, you can install it by typing brew install Caskroom/cask/inkscape. – jherran Jun 19 '15 at 7:16
  • ok, I installed homebrew cask, this seemed to make the installation work. Unfortunately inkscape still doesn't work from the command line (tells me failed to load the requested file) which makes it worthless to me. For some reason brew uninstall inkscape also doesn't work... – Shep Jun 19 '15 at 18:19
  • Try this: brew uninstall Caskroom/cask/inkscape – jherran Jun 19 '15 at 18:39
  • 2
    The "tap" command didn't work for me. I instead did brew install hombrew/x11/inkscape and that worked great. Might be something for the new version – danielson317 Jul 12 '15 at 22:14
2

This worked for me on Sierra (10.12.1) in December 2016.

brew update
brew cask install xquartz
brew cask install inkscape

Reboot machine.

Launch Inkscape from Applications directory. Wait a minute for the font cache to be built.

enter image description here

1

This worked for me on 10.10.4 with brew:

brew update
brew install homebrew/x11/inkscape

I actually didn't need to run brew tap homebrew/x11.

0

This works on Sierra 2017.

brew update
brew cask install xquartz

Restart your machine.

brew cask install inkscape
0

As authors in the official website says for Homebrew:

If you've previously installed inkscape you should clean it before next installation:

brew uninstall inkscape
brew cleanup

Installation:

brew install caskformula/caskformula/inkscape 
  • brew install caskformula/caskformula/inkscape would be for version 0.92.1 which does not (yet) have a dmg distribution. while brew cask install xquartz, brew cask install inkscape would be an alternative to dmg for a 0.91 stable install. hence, "cask" vs. "caskformula". – l --marc l May 25 '17 at 8:05
-1

I have installed it successfully with the following command line:

brew install caskformula/caskformula/inkscape

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .