2

I have set my dashboard as overlapped in system preferences, and I despite I have few widgets on it (just a calculator, a calendar and a clock), it takes all my CPU and memory:

enter image description here enter image description here

For now I've just disabled, but I find it useful and I'd like to know if there's a way to fix it.

  • Which widgets are you using? – William T Froggard Jun 18 '15 at 22:55
  • Ok I added a picture that shows the widgets. – Ramy Al Zuhouri Jun 18 '15 at 23:01
  • What's the name of that digital clock widget? – William T Froggard Jun 18 '15 at 23:04
  • Bin Digital Clock. – Ramy Al Zuhouri Jun 18 '15 at 23:10
  • 1
    I'll use your setup for awhile and see if I get similar results – William T Froggard Jun 18 '15 at 23:23
2

I seem to be getting the same issue. Even more interestingly, when I remove that digital clock widget, Dashboard seems to always freeze. It would seem likely that Big Digital Clock is the culprit here. It must be running in some sort of loop that not only makes its RAM usage balloon, but prevents Dashboard from closing it, and causes it to freeze.

enter image description here

This is after only a few minutes. Then I tried to remove Big Digital Clock, and Dashboard has been "Not Responding" ever since, although its RAM usage keeps climbing. Although this doesn't happen immediately. It would seem that the clock needs to be running for a few minutes before it exhibits this bug.

EDIT: It would seem the steps to trigger this bug are as follows (there may be a step or two in here not necessary, but this does it). Do this after removing all widgets to start fresh:

  1. Add Big Digital Clock
  2. Add calculator
  3. Do 2 + 2 (or some arbitrary calculation that you can hold down the enter key for awhile with) and hold down Enter for like 20 seconds
  4. Delete Calculator
  5. Add Calculator

After these steps are completed, Dashboard should start to bloat in a few minutes. You'll know you've done it right if you start seeing small CPU usage spikes with Dashboard every 15 seconds (this may be related to the 20 seconds or so of holding down return in calculator). After Dashboard bloats to about 1 GB of RAM, trying to get rid of Big Digital Clock, results in Dashboard going unresponsive.

The solution seems to be to remove Big Digital Clock, as it seems to be the source of this systematic bloat. Let me know if this experiment works for anyone else.

  • The above steps did not reproduce the bug (it seems to happen randomly for me), but I deleted Big Digital Clock and I'll try to use it a few then I'll let you know. – Ramy Al Zuhouri Jun 19 '15 at 9:50
  • @RamyAlZuhouri odd... It produced the bug fairly reliably for me. You do have to wait awhile though. – William T Froggard Jun 19 '15 at 9:51
  • Just did it again. The bloat starts very slowly, but eventually picks up steam. I actually had Dashboard at over 20GB earlier because I had forgotten that I'd set the bug in motion... Heh. Made for a very slow system. :) – William T Froggard Jun 19 '15 at 10:04
  • Confirmed to work on both of my Macs. – William T Froggard Jun 19 '15 at 10:15
  • After removing Big Digital Clock I'm not getting problems anymore, thank you. – Ramy Al Zuhouri Jun 19 '15 at 19:07
2

My Dashboard was running at 37% of CPU for a while. That's the 3.5 GHz Intel Core i5 in a Retina iMac of 2014 vintage. What seems to help is to cycle Dashboard off and then on again in Mission Control (in System Preferences). Good luck.

1

I had a delay before I could start interacting with dashboard apps (e.g. type into calculator). It turned out that if I remove the event list next to calendar by clicking on it, the delay got away.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .