3

Any help would be greatly appreciated, I've found so many similar questions but none that match mine exactly.

I created a partion on my 2013 iMac in order to test out the Yosemite upgrade. I decided to proceed with the upgrade from current Mavericks 10.9.5 but now I'm unable to reclaim the space dedicated to the Yosemite install, 1.5TB (half of my HD).

System info

GRAPHIC NVIDIAGeForceGTX775M 2GB GDDR5

PROCESSOR 3.5GHz Quad‑core Intel Core i7

MEMORY 32GB 1600MHz DDR3 SDRAM‑4X8GB

HARD DRIVE 3TB Fusion Drive

I was able to delete the partion, but the space allotted to it in disk utility is greyed out, and there is no drag to resize option for my remaining HD.

  • Ive tried in safe mode and recovery mode.
  • I've verified and repaired all disk permissions to no avail.

1) Has anyone successfully reclaimed entire HD after partitioning a Fusion drive

2) Based on the output below can someone help me identify the partition I created by either a UUID or Identifier? I've found many instructions online but dont know which disk/volume I should be attempting to resize/delete.

enter image description here

enter image description here

enter image description here

enter image description here

  • You would need to completely format the drive and start over. With a Fusion Drive (or any other Core Storage volume) you cannot resize partitions, and specifically with Fusion Drive, you cannot convert it to a non-Core Storage volume without losing Fusion Drive. – tubedogg Jun 18 '15 at 19:47
  • You could make a complete backup, boot into recovery, format the drive and then restore from backup. – tubedogg Jun 18 '15 at 19:48
  • 1
    no you don't. I'll post the steps in a sec – William T Froggard Jun 18 '15 at 19:52
  • I tried this and it almost worked. If I set the the size to 1.1t, I get this message: Error: -69771: The target disk is too small for this operation If I set it to 0.8t, I get this message: Error: -69771: The target disk is too small for this operation They seem to overlap. I think that I am at a point where I am way over my head! – Marty Miller Aug 25 '17 at 16:44
3

Run the following command in Terminal: diskutil cs resizeStack ACA4133B-5F31-4D66-B502-4EABED4E2958 5E6D00FD-4BAD-424C-92CF-F8080CCC2C95 3.128t

The first UUID is your LV UUID, the second is the PV UUID that you want to grow (incase I mistyped one of them).

This will grow your disk back to fill up your 3TB disk. You may have to reduce that number to 3.1279t or something though. 3.128t should work. Unfortunately, you can't specify 100% like you can with many commands.

  • OMG. You just fixed my problem in seconds. Thank you so much! I've burned almost a week trying to undo this mess. – JDough Jun 18 '15 at 20:05
  • You're quite welcome! :) – William T Froggard Jun 18 '15 at 20:08
  • Amazing help William. I've been testing out some things with Boot Camp this weekend only to find 200GB of my Fusion Drive no longer available. I used the logic you showed here and updated the UUID values to my own and violà. Great stuff, thanks! – Johnny Kutnowski Sep 13 '15 at 22:21
  • I had the same problem (but different specs) and this answer worked perfectly. – Big Mac Feb 19 at 18:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .