I've not ever wanted to use the Mail app on my Mavericks machine, but recently I decided I'd give it a shot. However when I went to Applications in Finder, I couldn't see it. Nor was it in ~/Applications (which is completely empty anyway).

Missing Mail Image

When I did a search from Terminal (find . -iname Mail.app), I discover that it is in the /Applications folder after all. I checked the permissions, but have never seen the "@" before:

drwxr-xr-x@  3 XXXX   admin    102 21 Feb  2014 MacX Free AVI Video Converter.app/
drwxr-xr-x@  3 root   wheel    102 16 Jul  2014 Mail.app/
drwxr-xr-x   3 root   wheel    102 16 Jul  2014 Maps.app/

The only way I could seem to open it was via Terminal (open /Applications/Mail.app).

Does anyone have any idea on why it might not be visible in Finder?

Note: The app itself is running fine after opening from Terminal... & I've since marked it as "Keep in Dock".

Many thanks, Craig.

  • If you change the Finder or dock view to list or grid does mail show up - perhaps the icon view has got scrambled up
    – mmmmmm
    Commented Jun 18, 2015 at 14:26
  • @Mark. No, still not visible. I tried changing sort as well.
    – cmroanirgo
    Commented Jun 18, 2015 at 14:43
  • What Icon is it showing in the Get Info window ?
    – Ruskes
    Commented Jun 18, 2015 at 16:45
  • If you show all hidden files is it still not in the Applications folder?
    – Zero
    Commented Jun 18, 2015 at 19:38
  • @Zero. Nice idea. After hunting around on how to do that I found defaults write com.apple.finder AppleShowAllFiles YES, Mail.app does appear. Obviously, I can't leave it this way...
    – cmroanirgo
    Commented Jun 18, 2015 at 21:31

1 Answer 1


Thanks to the hint from @Zero, there is a way to Hide and Show individual files, including applications from Finder by using Terminal.

To Show individual files:

sudo chflags nohidden Mail.app/

To Hide individual files:

sudo chflags hidden Mail.app/

Depending upon the file, you may not need to use sudo, but it won't hurt in any case (other than needing to type in a password).

Disclaimer: I found the key to my answer mentioned in a comment here: https://apple.stackexchange.com/a/65175/84492

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .