1

I've set up a VPN on my Mac mini using Server 4.1 with the "L2TP and PPTP" option set. I can connect to the VPN from my iPhone over my local network (Time Capsule) using L2TP but not PPTP. With the latter the VPN service log shows the error

DSAuth plugin: MPPE key required, but its retrieval failed.

I've Googled around the subject and found various answers saying my "VPN MPPE Key Access User" dismissing/corrupt and I need to recreate it using sudo vpnaddkeyagentuser /LDAPv3/127.0.0.1. These posts tend to point back to this article - https://support.apple.com/en-us/HT201828.

I've tried this, but I don't see the user being added to the list in Server (yes, I clicked on View > Show System Accounts).

  • I thought I had it! I'm not running Open Directory so there isn't an LDAP server on my network. I therefore need to run sudo vpnaddkeyagentuser without further arguments to add the missing account. And that does work - I can see it in the Server.app user list. However, I still get the MPPE key retrieval error. Grrrr! – kbro Jun 18 '15 at 2:50
  • The log also contains this - DSAuth plugin: unsupported authen authority: recved ShadowHash;HASHLIST:<SMB-NT,CRAM-MD5,RECOVERABLE,SALTED-SHA512-PBKDF2>, want ApplePasswordServer - relevant? – kbro Jun 18 '15 at 3:17
  • Open Directory log contains this - Client: vpnaddkeyagentu, UID: 0, EUID: 0, GID: 0, EGID: 0 Node: /Local/Default, Module: PlistFile - unable to update FDE password - missing critical information – kbro Jun 18 '15 at 3:59
  • Hmmm... serious lack of comment on this one! I did some more digging and found support.apple.com/en-gb/HT4748 which says "PPTP can only be used if you are managing network users or users connected to a directory server. Local user accounts can only be used with LT2P." so perhaps I'm flogging a dead horse. I know I used to be able to use PPTP with iVPN so perhaps I'll go back to that, or just stick with L2TP since it's working fine for me. – kbro Jun 18 '15 at 20:35
  • I have a similar problem in the revers though. PPTP is working fine but L2TP is not.. i am also running open directory on my Yosemite server. – user138593 Jul 31 '15 at 18:41
1

Sorry for being untechnical, but I solved a VPN/Yosemite issue: After a smaller Upgrade my VPN still connected, but didn’t let anything thru. The Update somehow „unchecked“ System Preferences > Network > VPN(PPTP) > More…/Options > Connecting Option > Send all traffic through VPN Connection (third option in the first list in this dialog; I'm translating/guessing from the german version). Setting it back to let everything go through resolved all issues; Mail, afp, ftp, vnc came back just like that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .