1

Okay, so I go to iTunes Connect to manage the contracts I have to sign to become a developer (yeah, fun stuff, and I got to encounter a bunch of fun puzzles on the way, see my Stack Overflow profile). I go to the "Agreements, Tax, and Banking" section and click "Contact Info" and fill that out. I then click the "Done" button on my screen. The dialog for it later disappears and so does my contact info. As in, when I go to select a contact for each thing listed there, the only thing selectable is Select.

Typically, I'd ask this on Stack Overflow, but it's not about programming. It's simply about the final information that's somehow even more confusing and makes you want to throw even more inanimate objects across the room. Any ideas on how to fix this in the sense where I can actually select my information?

0

I guess it worked after I tried it repetitively. Apple has forms that haven't been updated for a couple years, considering their extensive use of Lucida Grande as a font.

0

I had the same issue and found that switching from Firefox to Google Chrome solved it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .