1

I can connect my daughter's MacBook to the wireless router but not browse the internet with two different browsers (Firefox and Safari). This is a recent development as she has successfully browsed the net with this MacBook earlier. She says that she didn't change any settings.

Her MacBook is given an IP address by the wireless router's DHCP server. I can ping other computers on the LAN as well as on the WAN (but only using an IP address with the ping command). In other words, I can ping 8.8.8.8 but not google.com. My router's log does not log any requests from her macbook. Other computers on this LAN have unrestricted access to internet browsing.

ifconfig en1 returns...

en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
     ether 00:23:12:55:3b:a0
     inet6 fe80::223:12ff:fe55:3ba0%en1 prefixlen 64 scopid 0x5
     inet 192.168.1.9 netmask 0xffffff00 broadcast 192.168.1.255
     nd6 options=1<PERFORMNUD>
     media: autoselect
     status: active

I've tried rebooting the computer and the router.
Any help trouble shooting this would be greatly appreciated. to clarify my original question based on comments that I've gotten...

@Buscar I was only connected via wifi when I ran the ifconfig so the en1 must be wifi.

@Jamie I checked the DNS servers listed in the router status and got 208.180.42.68 208.180.42.100 and I can ping these from my daughter's macbook. It is curious that my Netgear router doesn't log any requests from the macbook. Also, the App Store on the macbook indicates that there are 2 items in the queue (icon in the dock) but when I click on that icon the App store doesn't finish loading (probably because it cannot connect [on a different port than 80???]).

I also tried dig and nslookup. These both had connection time outs. Thanks again for your help

  • it appears to be a DNS resolution problem, what are the DNS servers listed on the wireless connection? – Jaime Santa Cruz Jun 17 '15 at 3:44
  • How come you are using Ethernet (en1) and not WiFi (en0) – Ruskes Jun 17 '15 at 4:12
  • @Buscar웃SD what makes you say en1 is not Wi-Fi in this case? If it was an Ethernet connection it should show the link speed next to media. On my mini right now, en1 is the Wi-Fi connection. Agreed with Jaime it is almost certainly a DNS failure, whether in the router or on the MB. – tubedogg Jun 17 '15 at 6:17
  • Also, the fact that you can ping IPs on the WAN means it is connecting to the Internet, but DNS is not working. – tubedogg Jun 17 '15 at 6:23
1

Ok, I've figured the problem out in my daughter's macbook. System>Network>Wi-Fi>Advanced DNS tab. I removed the existing DNS servers and used Google's 8.8.8.8, 8.8.4.4. Reopened the browser and it is working now. nslookup and dig also work. Not sure where the DNS servers that I replaced were from or how they got there. I also noticed that in my macbook (one of the ones that were working fine), the DNS server is the wifi router ipaddress. I'm not sure if I should use that or just stick with Googles. Hope this helps someone.

  • Generally the DNS server should be set to the default (router), unless you have a specific reason for not doing so, such as wanting to use Google DNS and your router not supporting overriding your ISP's DNS servers. – tubedogg Jun 22 '15 at 5:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .