29

The Terminal app uses bash by default. And I don't want to change it. However I want to configure iTerm2 with zshell and oh my zsh. and I don't want bash on it. The instructions I checked online, make zshell default in both apps.

2 Answers 2

54

If your default system shell is bash, your Terminal should start with it. You can check it on General tab under Terminal Preferences. Should look like the following:

enter image description here

If bash isn't your default shell, you can change it by typing:

chsh -s /bin/bash

To configure iTerm2 with zsh you have to open Preferences and change the command on General tab on your default profile. You have to enter /bin/zsh or whatever shell you want.

some text here

To install oh-my-zsh type the following:

sh -c "$(curl -fsSL https://raw.github.com/robbyrussell/oh-my-zsh/master/tools/install.sh)"
4
  • 3
    Should it actually be chsh -s /bin/bash (-s, not -c)? I get chsh: illegal option -- c...
    – XML
    Mar 25, 2016 at 9:56
  • Perhaps /bin/zsh -l in the iTerm2 configuration would be closer to what the OP had in mind? BTW, what's the point in doing a chsh? The OP said that he already does have bash as default login shell on his platform anyway. Dec 27, 2022 at 10:02
  • For me, only chsh -s /bin/bash worked. The GUI command did not.
    – K.S.
    Jun 27, 2023 at 20:01
  • This is out of date. Dec 8, 2023 at 22:49
4

Update Dec 2022

You need to go to:

  1. Preferences
  2. Profiles tab
  3. Select Command in the drop down
  4. Enter /bin/zsh/ in the text input

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .