The Bit-torrent Transmission application will not let me quit it in my Mac (latest OS X). Actually the icon says "application not responding". When I open up activity monitor it is not there. Also, when I look it up using Terminal it will not find it either. I tried to restart the computer via Terminal but it will not let me enter my password.

What should I do?

  • The password in Terminal is never displayed as you're typing. Did you try typing it and pushing enter? Jun 16, 2015 at 0:03
  • What application? or shall we guess it :) or do you mean the bittorrent Transmission app. transmissionbt.com
    – Ruskes
    Jun 16, 2015 at 0:13
  • I think it is Transmission according to OP. IIRC it is a Torrent client.
    – bjbk
    Jun 16, 2015 at 0:14
  • are you running it with Inspector open?
    – Ruskes
    Jun 16, 2015 at 0:57

1 Answer 1


So many options!

  1. (My favorite) Option-right click (or control-option-click) on the offending application's icon in the dock, and click "Force Quit". If it doesn't respond immediately, try one or two more times.
  2. Open Activity Monitor, make sure it says "All Processes" at the top. If it doesn't, select "All Processes" from the View menu (or the pop-up menu in the toolbar on older versions of OS X). Click the Force Quit button at the top left.
  3. Open up terminal, and run sudo killall <appname>. This is usually the application name, minus the .app part. When it asks you for your password (after reading you the riot act if this is your first time sudoing), type your password and hit enter. The cursor will stay still when you type your password; you will not see characters or • dots.
  4. More direct option -- use Activity Monitor to determine the PID (process ID) of the offending application or process, and then run sudo kill -s KILL <pid> in Terminal.

BE CAREFUL when using sudo.

  • 1
    None of those works. I have tried all of them before as well.
    – Marion
    Jun 16, 2015 at 4:49
  • Try killing the dock. It will restart immediately on its own, and should be more consistent with reality afterwards. Can you describe the problem any more? Are the windows for Transmission visible, and can you interact with it? What happens when you try to restart from the Finder as usual?
    – NReilingh
    Jun 16, 2015 at 4:58
  • I cannot restart the Finder (when I try to kill it I get the characteristic refusing sound). How to do so? How to kill the dock? The transmission windows are not visible. The icon of the dock is only saying it is not responding. When I try to restart the Mac from the Finder after a while it tells me that restart failed because Transmission is still open and I should terminate it, that is, it cannot automatically terminate it as it would do with the other apps.
    – Marion
    Jun 16, 2015 at 9:54
  • Use any one of methods 2-4 to terminate the dock. If that still doesn't work, try terminating the entire loginwindow process -- that will end your session and bring you back to the login screen. The terminal command to force an immediate and non-ignorable reboot is sudo shutdown -r NOW.
    – NReilingh
    Jun 16, 2015 at 16:09
  • I did use the NOW command last night. Nothing. I did just reboot it with the turn on button, I hope that it won't hurt the HDD too much.
    – Marion
    Jun 16, 2015 at 16:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .