Since a few days, I am not being able to press T and any other key on my Wired Apple Keyboard. Nothing happens when I press Shift and T. Keyboard shortcuts like Command ⌘ShiftT don't work. But Command ⌘T works.

To get a capital T, I need to turn on Caps Lock or copy and paste it from somewhere.

I enabled Verbose Boot by setting the kernel flags a long while ago. Maybe at the same time when the key stopped working right1, after 20 lines of text the verbose boot kept typing in the $ character automatically until I pressed any key on the keyboard.

I can fix this by attaching a non-Apple Keyboard, setting its layout and unplugging it, after which the Apple Keyboard starts working perfectly (which means there is no hardware problem). But when I reboot the key stops working again.

Also trying to press ShiftT in verbose boot does nothing, while other keys show up fine. ShiftT doesn't even work in Safari in Recovery mode. I also can't reset the NVRAM by pressing Command ⌘Option ⌥PR, it just takes me to Recovery mode.

1 I don't remember doing anything except setting up oh-my-zsh around this time.

  • Ever consider your keyboard itself may be damaged?
    – Joe Sewell
    Jun 15, 2015 at 20:44
  • Also check out this question.
    – Joe Sewell
    Jun 15, 2015 at 20:45
  • No hardware problem. Updated question.
    – Elmo
    Jun 16, 2015 at 5:13
  • Have you double checked the system preferences for things like speech to make sure this combo has not been set as a trigger for some function? Jun 16, 2015 at 9:54
  • Yes. Even in recovery mode, pressing shift+t does nothing.
    – Elmo
    Jun 16, 2015 at 14:48

3 Answers 3


Try the following:

  1. Open the "Keyboard" preferences pane
  2. In the "Keyboard" tab, turn on the "Show Keyboard and Character Viewers in menu bar" checkbox
  3. Go to the new menu (it looks like a box with a command key clover-leaf in it) and choose "Show Keyboard Viewer"

You'll now see a window shaped like your keyboard, with every key shown, and each pressed key highlighted. Try out all the keys, especially the "t" and modifiers. Note that holding down "shift" will change the key display to capitals, and holding down "option" will change the key display to alternate characters. This should let you track down the problem, if it's in hardware.

  • I tried it already, all keys work fine when individually pressed. When I hold Shift, I can see it on the screen but when I press T, nothing happens.
    – Elmo
    Jun 16, 2015 at 5:10
  • So, "T" works, "Shift" works, but "Shift-T" doesn't? Do you get the same result with either "Shift" key? And, do you have a keyboard macro program running that might be causing this? Jun 16, 2015 at 9:39
  • Yes, yes, no. Even in recovery mode I can't press shift t. It is not a hardware problem as I can fix the problem until the next boot by plugging and unplugging a non-Apple keyboard.
    – Elmo
    Jun 16, 2015 at 14:47

I happen to have run into this today though probably for an unrelated reason, but maybe this will help someone else. I had recently installed Snap Camera and bound Shift-T and Shift-O to actions in the app. What I didn't realize was that the app stayed open in the background (with a menubar icon) and was capturing those keystrokes as long as it was running.

Holding down the Fn key is a good way to test for a hardware issue because the Shift-T and Shift-O keystrokes worked perfectly when holding down Fn.

It's likely this could happen for other apps that are doing systemwide keyboard capture of a specific keystroke.

Note to self: Always add modifier keys like Command, Option, Control when binding keys in something that's going to be listening in the background.


I just experienced this issue and found that the problem was with a USB wireless mouse receiver. Per Daniel Griscom's answer, I went into the keyboard settings but then happened to go into the "Modifier Keys" dialog. In that dialog there's a dropdown which shows the different input devices and when I expanded the list, I found that there were 2 mouse receivers listed (in addition to my usb apple keyboard). It was then that I realized that at some point in the past I had forgotten to unplug the receiver for a mouse (that I no longer have).

I'm still not sure what caused the problem to begin with but unplugging the extra receiver fixed it and have regained the ability to type an upper-case T.

Not the answer you're looking for? Browse other questions tagged .