1

I upgraded from OS 10.7.3 to 10.10.3. Now I get "permission denied" when I run mkdir on folders that I own and have full permission.

For example : I own a folder called "/library/webserver/documents". I try to make a subfolder and I get permission denied. I verified that I am logged in as the user that owns the folder. The permissions on it are 755.

A few days ago, when I was still on 10.7.3, I did not have this problem.

What is the solution? I don't want to simply type "sudo [command]" every time I want to make a folder. I just want to use the terminal like it worked before.

1

I mentioned I owned the directory. I just found out that I actually owned the symbolic link to the directory. The user 'root' owned the directory. I chowned the directory and it works ok now.

My guess is either the upgrade changed the owner of the directory or else it changed the permissions logic regarding symbolic links.

1

/Library and all subdirectories are owned by root

I think upgrading the OS restored permissions.

The directory that you own that the web server can see used to be ~/Sites but since Mountain Lion setting this up is more complex not just tick click on an option in system preferences e.g see this article (NB it looks reasonable but I have not tried it)

0

I see you didn't own the directory. Another tip to check the owner is issuing:

namei -l /path/to/directory

NOTE: You have to port install namei because it is not native on mac

Also, repair disk permissions if some directory has incorrect permissions. If something has to be root and you don't want to type sudo everytime, the. you can issue sudo su or sudo - i* in startup which will provide you with a root console. Exit this by typing exit.

*= If you want the difference between su and -i, refer to this. In a nutshell, -i is your user with elevated privileges, and su is a non login shell (root@root~#)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .