13

This question already has an answer here:

If I press Escape by mistake while working, it exits full screen mode.

I could use Ctrl+Cmd+F if I want to exit full screen mode. How can I prevent Escape key in full screen mode?

marked as duplicate by bmike Sep 28 '15 at 21:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You can set this in System Preferences > Keyboard > Shortcuts. Look for the escape key, replace it with something else. Add a keyboard shortcut (If there isn't an existing one) And set Ctrl+Cmd+F to exit fullscreen. You can make an automator service to exit fullscreen if there isn't a function on it already (I am not on my mac now, so I cannot be 100% sure) – TheBro21 Jun 15 '15 at 7:14
  • Thanks The Bro21, I could see the 'Launchpad & Dock', 'Mission Control', 'Keyboard', 'Input Sources' 'Screen Shots', 'Services', 'Spotlight', 'Accessibility', 'App Shortcuts', but I couldn't see any assignment to 'ESC' key now. sad.. But I appreciate your contribution. – Charles Yeum Jun 17 '15 at 0:05
  • I think you double click the service, then press ESC to assign – TheBro21 Jun 17 '15 at 12:17
  • As far as I can tell, the service is not available to change the shortcut. – Jim Greer Jun 1 '16 at 18:03
1

Now, you could go ahead and brute-force disable the Escape key in Safari. But that'd defeat the purpose of still allowing Escape to work as a shortcut in the aforementioned places, which I'd rather avoid.

enter image description here

http://patricklenz.co/blog/2014/9/1/dont-escape-full-screen-mode-in-safari

Btw I think that your question is a duplicate : Disable Escape key in Safari for getting out of full screen mode

Not the answer you're looking for? Browse other questions tagged .