2

I've been using Keynote (6.5.3) for nearly a month without trouble. Apparently, at some point today, I've mashed a keyboard combination that presents me with a popup dialog with "autocomplete" suggestions as evidenced below.

What happens when I hit "escape" key

I've seen comments indicating that I should not be surprised, that this is default system behavior, and that it is not behavior of Keynote in particular. It's surprising because until about 15 minutes ago, hitting escape would remove focus from the textbox and select the textbox object itself.

As it stands, I'm actually unable to figure out how to delete a number of text boxes in my slides. A separate side-effect seems to be that the cursor remains in the selected text box even if I select a separate element. For example, note that the cursor is positioned after the word "Wait" in the title of the slide, while the body content of the slide is selected. If I press "delete", ⌘-X, or any other hotkey that I would expect would remove the selected text object takes effect at the cursor. I promise you these are separate text objects and there is no grouping.

Cursor stays active despite separate object selection

I've looked through all the keyboard settings in System Preferences, including all shortcuts, reset the shortcuts, scoured for anything in the accessibility menu, all to no avail. I found out that this is supposedly normal behavior for option-escape, but I am not holding down the option key.

The suggestion at my first link to use ⌘↩ to remove cursor focus from the active text box does not work.

Restarting Keynote seems to do the trick, so it seems to be related to some option that affects Keynote's behavior with text boxes specifically. I'd be surprised if I ran into this behavior again, and it's good to know restart fixes it, but that's pretty annoying from a workflow perspective.

Does anybody have the slightest idea how this might happened and how to turn off that behavior?

You must log in to answer this question.

Browse other questions tagged .