1

I bought by mistake a fake MagSafe 2 charger for my Macbook Pro 13 Retina. After using it for around a month I decided to pay more and buy the original one for the sake of my battery health. After opening the box and plugin it in, it just didn't light up, I've tried many times and nothing.

The new charger works on my girlfriends MacBook without any problems and the fake one still works on mine! Both chargers are 60W MagSafe 2 (the proper one).

I tried reseting SMC and PRAM, but no luck.

Did anyone have this problem, what could it be?

2

Sounds like a DC-In board or logic board issue. It could be possible that the fake one cooked the parts of the logic board which provide the onewire communication between the SMC and adapter. Before you go replacing parts, make sure the contacts are clean on both the rMBP and MS2 adapter. Ensure no pins are pushed in and stuck on the adapter. Also ensure that the DC-In board did not get pushed in.

If it is new enough, it should still be covered under AppleCare, and you can take it into a ACSP for them to take a look at. Don't mention any fake charger should you take it in for service. If you're lucky, it's just a DC board, so here's hoping.

Sorry I can't provide much more help, it's hard to diagnose HW problems without having the machine in front of me with known-good parts to swap and test.

  • 1
    Thanks, but if something is cooked, how is it possible the fake adapter still works? – Agu Dondo Jun 14 '15 at 17:15
  • 2
    fake charger doesn't rely on the Apple circuitry, just pumps voltage into the machine til it cooks. – Tetsujin Jun 14 '15 at 17:24
  • It was! I changed the DC-In connector on the macbook for a new one and everything worked normally. Thanks a lot. – Agu Dondo Jan 24 '16 at 21:37
1

Just try to open your MacBook Pro's back cover, unplug the cable from the battery to the logic board. Keep it unplugged for a couple of seconds.
Then reconnect the cable from the battery to the logic board an reassemble the cover of your MacBook Pro, reconnect the charger and it should be all good to go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .