0

I have an iMac from 2007-2009 and I want to upgrade the software to improve performance.

It's running Mac OS X 10.5.8 on an Intel Core 2 Duo processor (2.66 GHz). It displays 4 GB of memory and 451.6 available GB on the harddrive.

Should I try to upgrade to Snow Leopard and then to Yosemite? Snow Leopard requires 5 GB of free hard drive disk space and 1 GB of RAM. (I don't know how much RAM I have.) Yosemite requires 5.64 GB.

  • 2
    need to know the exact model - Apple menu > About this Mac (will also tell you how much RAM you have) – Tetsujin Jun 14 '15 at 16:40
  • 1
    I probably would not go to Yosemite with a Mac that old, even if it's possible. – tubedogg Jun 14 '15 at 17:53
  • 1
    then as Mike says, it can run Yosemite - but as tubedogg points out, you may not want to. Maybe stop at Snow, or Lion - it's not something I've ever tried, so I can't really say, tbh. – Tetsujin Jun 15 '15 at 5:41
  • 1
    I wouldn't necessarily agree with @Tetsujin. I run Yosemite on my late 2010 MacBook Air, which is considerably less powerful than your iMac (same RAM but only a 1.6GHz CPU), and it runs perfectly. Admittedly it has an SSD rather than a hard disk, and that makes a big difference. – Mike Scott Jun 15 '15 at 5:58
  • 1
    @MikeScott - it's the kind of thing I'd test out with a full backup before each step; so I could go back if I wasn't happy. I'm pretty sure Yosemite makes good use of an SSD for RAM/swap handling. I don't have a machine with a boot HD any more, but I set one up for someone last week & noticed how slow it felt with an HD instead of SSD. – Tetsujin Jun 15 '15 at 6:00
1

Every iMac from the mid-2007 release onwards can run Yosemite, and the last model that couldn't could also only address 3GB of RAM. So it's almost certain that your iMac will be able to run Yosemite.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .