2

Specs: Macbook Pro Mid 2012 OS X 10.10.4

I'm not able to Share my screen with my friends. I want to connect with my friend's Macbook (which is not in my network, different city) for troubleshooting purposes, & so I tried Screen Sharing from Messages App:

Messages

After I click 'Ask to share screen', it does send a request to the other Mac for permission, after he click on 'Allow', nothing happens!?

[ The Screen Sharing option is turned ON & Remote Management is turned OFF, on my Mac as well as on my friend's Mac.]

System Preferences Setting

How do I connect with his computer, & control it over internet, It'll be very convenient for troubleshooting purposes.

Thanks!

  • Are you sharing on the same LAN segment or are you going across your router? – Allan Jun 14 '15 at 12:13
  • @Allan : We're not in the same network, different city. – Satyajeet Jun 14 '15 at 12:28
  • Then it sounds like it is blocked at your firewall. I will create an answer that references a solution – Allan Jun 14 '15 at 12:38
2

If you are not connected on the same LAN segment (both computers on the same network) and you are going through a router, chances are the router's firewall is blocking the connection.

What you have to do is open/forward the ports on the router Apple screenshare (remote desktop) uses to communicate. The ports are:

TCP: 5900, 5988
UDP: 5900, 3283

Screen sharing behind a firewall-- What ports?

One thing that I personally like to do is test out on the same LAN segment first (behind the router firewall). This way I know that my machine is fully functioning and the service is working properly. This way, when trying to troubleshoot a connection issue across the router, the changes of it being my machine is greatly reduced.

You will need to edit your REMOTE router to allow incoming connections of the ports that I mentioned. You do this by:

1) Find out what IP address the computer is using

2) Go into the router admin page via web browser (it will the the "router" address in your network settings. You will need the username and password.

3) Under Firewall, you may see an option to forward different ports. Create entries for the ports listed above. In each entry you should have a "source" and a "destination." In source, leave blank for "all" and for destination, enter the IP address you got in step one. This will forward all traffic from these ports to the computer.

4) You should now connect over the internet.

If that doesn't work, I suggest looking into TeamViewer. It's a third party solution, you will need the software on both machines and it is a bit slower. However it is much easier than configuring a router.

  • Yes, I'm connected through a router only, but I've no idea how to open/forward the ports you've mentioned to disable the router's firewall. I've also tested screen sharing from within the same LAN segment, both the machines were on the same network, and it worked perfectly, so the machine is fully functioning and the service is too working properly. – Satyajeet Jun 14 '15 at 20:16
  • Can you tell me a little more about how do I open those particular ports? – Satyajeet Jun 14 '15 at 20:17
  • Most likely, you will have to configure the connection at the remote end, not what is local to you. Since I don't know specifically what router you have there, I can only tell you generically. I will edit my answer for your reference. – Allan Jun 15 '15 at 0:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .