0

I've got a quite old Samsung printer, model ML-1520. I can not find any drivers for it. Samsung seems to have stopped supporting OS X, and Apple only offers drivers for models not older than ML-1630.

I've tried to install the drivers by Apple and setup my printer as 1630 and other models, but it doesn't print.

Where can I find proper drivers?

(I'm writing both Q&A. For the purpose of search optimization I've added extra vendors in the header. My solution is applicable to all those vendors).

1

First to do: check if your printer is supported by Apple. It was not true in my case, but may be true in yours.

There are at least two opensource driver packages, supporting the printers which are abandoned by their vendors:

SpliX.

a set of CUPS Printer drivers for SPL (Samsung Printer Language) printers. If you have a such printer, you need to download and use SpliX.

Supported Printers

  • Dell 1100, 1110
  • Samsung CLP-200, CLP-300, CLP-500, CLP-600, CLP-610, CLX-216X, CLX-2170, CLX-3160, ML-1510, ML-1520, ML-1610, ML-1630, ML-1710, ML-1740, ML-1750, ML-2010, ML-2150, ML-2250, ML-2510, ML-2550, ML-2571, ML-3050, ML-3560
  • Xerox Phaser 3115, 3116, 3117, 3120, 3121, 3122, 3130, 3150, 3420, 3425, 5500, 6100, 6110

Samsung-GDI for Mac OS X

Supported Printers

  • Generic GDI Printer
  • Lexmark
  • Samsung ML-200, ML-210, ML-1000, ML-1010, ML-1020, ML-1200, ML-1210, ML-1220, ML-1410, ML-1430, ML-1440, ML-1510, ML-1520, ML-1610, ML-1710, ML-1740, ML-1750, ML-2010, ML-2150, ML-2250, ML-2550, ML-4500, ML-5080, ML-6040

Personal experience

I first installed SpliX and it worked well with documents printed from MS Word or PDFs. But it failed with printing .jpg images from Preview app or command-line lpr utility. So I switched to Samsung-GDI, which handles .jpg well.

Also, if a printer is set up twice with different drivers it doesn't work with any of them. So you should only have one printer in Settings > Printers (per each device). You can have both driver packs installed on your system, though.

Similar problem was discussed in Xerox 3117 driver for OS X Yosemite

| improve this answer | |
  • any luck with with OSX 10.14.x (Mojave)? i have a Samsung ML-1740. SpliX v1 & v2 wouldn't install. – sonjz Jul 23 '19 at 14:14
1

For Samsung Printer Drivers on 10.14.x Mojave, this worked!

  • Download http://splix.ap2c.org/ and unzip to get PPDs

    • Select the PPD for your printer, mine was Samsung ML-1740 ml1740pt.ppd
  • Download http://guigo.us/mac/splix/ Download and install SpliX 2.0.0

    • It will fail, that's OK, it still installs the prerequisities
    • Go to System Preferences > Printers > Install Printer > Select USB Printer > Select Other Driver > Select the PPD file.

References:

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .