1

I have a problem with creating home folders on the server for network accounts. The goal is to share the same files on multiple devices. A quick overview of what I do:

  1. I go to the Server.app.
  2. I create a folder (in my case on /Volumes/Macintosh HD/Network Users).
  3. I enable the File Sharing service.
  4. I add the /Volumes/Macintosh HD/Network Users as a shared folder.
  5. Once added, I edit it and make sure it is able to be used for home folders (AFP).
  6. I create a new network account and set his/her home folder location to 'Network Users'.

When I try to log in on a device (in my case a MacBook Pro), it gives me the following error saying I can't login:

You are unable to login to the user account "williamdedwards" at this time. Logging in to the account failed because an error occurred.

I am 100% sure that this is related to the permissions. When I add my user account manually and give it Read/Write access to the 'Network Users' folder, it used to work (not anymore, I still get the same error now). When I set the home folder to 'Local', I can login and everything is fine.

I also came to this conclusion with Apple Support.

What am I doing wrong here?

0
+100

It might be something with the authentication process of the clients. Open Directory needs to be running on the server (try to delete and rebuild it) and this server must be assigned as a directory server in the the clients account preferences. You might be able to check permissions by accessing the a home folder via CMD-K and the AFP:// URL from the Finder of any client. If you get read/write access then permissions should be okay.

  • I found out that all home directories have Read/Write permissions for the user they're meant for. Would a video of what I'm exactly doing be helpful? – William Edwards Jun 17 '15 at 6:03
  • Don't know if a video would help that much. Usually you need to look at the log files and see, what's going (wr)on(g). There are a few more questions: Is the user in question also the owner of the home directory? Are you using domain names or IP addresses? – awado Jun 17 '15 at 8:39
  • Where are the log files located? As for your questions, I'm not sure where I can see the owner of the folder in the GUI. Binding to the Open Directory is done with the .private (the Server.app is set to Internet and VPN). – William Edwards Jun 17 '15 at 12:05
  • I meant the log files on the clients. Just see under "All Messages" in the Console there. That will be the most interesting part here. You can see the owner of a folder in the Server App: Server -> (your server) -> Storage -> navigate to the shares in question and select it. The gear symbol at the bottom shows the permissions. The first one is the owner (2nd = group, 3rd = others). If the server is named "server.private", can you do a successful lookup / reverse lookup from the clients on server.private? – awado Jun 17 '15 at 17:44
  • DNS lookup: dig server.private | DNS reverse lookup: dig -x 192.168.xxx.xxx – awado Jun 17 '15 at 17:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .