0

I have 2 computers. One is Mavericks (10.9.5) and this one is Yosemite. On Mavericks, this works flawlessly. With wine, Steam launches fine. However, there is a peculiar window showing up, and whenever I try launching a game/app, it pops the usual window with "Preparing to launch...", then it disappears and nothing happens.

enter image description here

The image on top shows the unusual window showing up next to the main window.

enter image description here

This is my setup in Wineskin of Steam (needs -no-dwrite because else, it shows blank buttons).

Here and here are the 2 Last Run log files.

UPDATE:

Reinstalling didn't help, and I figured out what the little window is. On Mavericks, it was on the navbar on top, and on yosemite, it is in this window. Clicking it shows the same options as the Steam icon on the navbar on Mavericks. Also, I may have found something related in the logs:

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. 
Makesure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

I am using OS X Yosemite (10.10.3)

  • Just to add, I am attempting to re-install now, and use an older engine. – TheBro21 Jun 13 '15 at 7:40
4

The difference may be related to whether you're using the Mac driver. Go to Set Screen Options, and check Use Mac Driver instead of X11. It's the top checkbox under "Other Options". Screenshot of Set Screen Options window

Otherwise, it's not clear how your installations are different. Because you're using Wineskin, however, you have a great alternative: Just copy the Wineskin app from your working computer to this one. That will carry along all of the settings and tweaks you have in your working copy. It's all self-contained!

  • That worked. The window now shows in the navbar as well. My failed solution was to try to use XQuartz. It didn't work though. – TheBro21 Jun 13 '15 at 16:23
  • i try to lauch cuphead but it gets to the first screen and just freezes help – cup head w Apr 3 '18 at 1:10
-3

it's something about 32bit vs. 64bit.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • No it's not. I already accepted the answer above, saying it is an X11 problem – TheBro21 Feb 14 '16 at 14:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .