1

I published an application in the App Store named HIV Clinical Guide. This application is more than 100 MB, so it is not possible to download it on a cellular network. Normally when you press the download icon in the App Store, you get a popup that you can only download the app on Wi-Fi, because Apple doesn't allow you to download an application that is more than 100 MB by 3G/4G.

The problem is that with my application, the download starts (you see the blue square), but is not really downloading (because using cellular). When switching to Wi-Fi, the circle is filled (so the app is downloading).

The question is why the user doesn't get the popup when on cellular? Now it looks like that notting is happening (and that's correct) but now we get a lot of questions why the app is not downloading.

I cannot find anything about this. Everywhere I look the documentation says that you get a popup…

Any ideas?

  • What version of iOS are you referring to here? – grg Jun 12 '15 at 20:07
  • I am not referreing to one specific iOS version. It happens on all the iOS versions when downloading cellulary – Gerco Brandwijk Jun 12 '15 at 20:08
  • Are you sure that it is only your application and not something that is wrong with the device you are trying it on? – Dempa Jun 12 '15 at 20:09
  • Yes, I am sure that it is not only happening on my phone only. You can try it yourself when you have an iPhone/iPad ;) – Gerco Brandwijk Jun 12 '15 at 20:10
  • @GercoBrandwijk I tried downloading your app and I saw the same problem. But I also noticed that I do not get the popup on other apps either. Normally it does come up but now when I tried with an another app over 100MB it didn't. If you try now to download an another app that is over 100MB over cellular, do you get the pop-up? – Dempa Jun 12 '15 at 20:19
1

Tried to download both the Askers application and an another application over 100MB. Neither I nor the Asker did get the pop-up about downloading large apps over cellular.

It looks like it is a temporary issue with the AppStore.
My recommendation is that you try again tomorrow or the day after that and see if the issue have fixed it self. If not, then you can continue further investigation in the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .