When I charge my iPhone 4 on my laptop, it starts charging but then it keeps going on and off charging even though it's not touched. It charges fine with a plug charger or with any computers I use at college.

What things prevent a Mac from charging a connected iPhone so that charging can be resumed?

  • 3
    The port isn't dirty, the cable isn't broken, the Macbook Pro is charged up. Every "solution" I see online is NOT the problem in my case. It feels like a software glitch or something. Someone explain what's happening... PLEASE! – Michael Wood Mar 31 '18 at 2:46
  • I'm having this problem (seemingly) totally randomly. Sometimes it happens when my iPhone (6S plus) is plugged into my Macbook Pro, sometimes it's when it's plugged into an outlet on a power strip (via a USB charger block thing). Sometimes it charges just fine, sometimes it does the constant on/off thing. There seems to be no rhyme or reason about WHY it's happening. It tends to do the "on/off" dance in a consistent pattern for a while, and then it will stop - just charging normally for about a minute - and then goes back to the "on/off" dance again. SOOOO annoying! – Michael Wood Mar 31 '18 at 2:46
  • 1
  • 1
    Same problem. So annoying. Apple please fix your bugs! – GN. Jun 16 '19 at 20:29
  • In my case it turned out to be a problem with the port on my MacBook Pro. When I connect the iPhone via another port, it works fine. – Hashim Akhtar Aug 21 '19 at 13:55

10 Answers 10


Running this in terminal worked for me: (it will ask for your user's password)

sudo killall -STOP -c usbd

This pauses the troublesome process instead of killing it altogether like other answers suggest. The difference is that macOS won't try to reopen it automatically and cause the issue again.

Running sudo killall -CONT usbd will resume the process, should anything require it.

Tested on: iPhone 7 (iOS 11) + MacBook Pro Late 2013 (10.13.6)

Besides software issues, there's a good chance that the cable is at least partially damaged so it might work for dumb power chargers but not with a MacBook that also relies on the USB data pins.

Also this might happen when either device needs an update. I've been asked "Install update to connect to device?" before and if I don't accept, this issue happens.

  • 2
    This worked for me, while killing usbd (in Activity Monitor) didn't. – Adam Aug 20 '18 at 23:06
  • 7
    You got to be kidding me. This worked :) – Vandan Patel Mar 27 '19 at 17:21
  • It works for me! Thank you. – Dmitry Kolesnikovich Jul 19 '19 at 16:26
  • 1
    Is it possible that root cause could be not original wire? – Alex Amorales Aug 31 '19 at 20:45
  • Thank you, this worked fine with my iphone 6s,(ios 12.4) on Macbook pro (MacOS Mojave) – Hriju Sep 11 '19 at 16:50

Force quitting the process usbd made this bug finally go away on my 2017 MacBook Pro.


You probably have a buildup of lint/debris in the phone's charger (lightning) port. Use a plastic or wood toothpic to gently scrape inside the port. Do not use a paper clip, or any other metal obeject! I had the same issue with a two year old iphone 6 and retreived enough lint to knit a sweater. It charges without interuption now.

  • 1
    man, this helped me. I have iphone cable that I used only for iphone debugging (50 times or so) and it just started going on/off when I connected it today - I even thought apple might determine cable age and disable it, but then I found your answer and it helped a lot. thank you so much. I also suggest inensively plugging USB in/out several times after cleaning – godblessstrawberry Mar 7 '18 at 12:30

Plug in your phone. Open Activity Monitor app. Search for 'usbd'. Click Quit and then Force Quit.

  • 1
    omg - THIS - i have had this problem for years..... Why??? – Bysander Jun 27 '19 at 17:36
  • 1
    You must have your iPhone plugged in while you’re killing the process or MacOS will just relaunch it when you plug your phone in. – weberc2 Jun 27 '19 at 21:45

Ankit Chhajed's solution allowed me to find a workaround. This isn't really a solution since Apple still has a software bug, but you can do the following:

  1. Stop iTunes (very important)

  2. Find and kill the "usbd" process in process list (must not be running)

  3. Attach iPhone

  • How do you kill usbd? Its a root process – GN. Jun 16 '19 at 20:31
  • @GN. sudo killall -STOP -c usbd by answer at the top! – anki Jun 17 '19 at 16:09
  • Stop Music App - this was important indeed. Now it doesn't charge but I can use Android Studio. – Slawa Dec 8 '19 at 21:53

I have the same problem with an iPhone XS and two different Macs, and no luck with any of the solutions that worked for other people.

I finally figured out a workaround today:

It works as long as I connect it to a USB hub that's connected to my Mac. (Yes, I'm serious. It doesn't even have to be an active hub, I'm simply using a $10 passive one, and iTunes and Xcode work like a charm.)

What also works is booting my Mac into Windows (via boot camp), then connecting it. Worth it if you simply want to back it up to iTunes and take it to the Genius bar.

  • Thanks, problem Solved. Used a USB hub on the macbook and connected the phone through this. Everything worked fine. First killed the usbd though. Killing the process did not work. then tried with USB hub. So try to kill the usbd first(see the earlier answer) and then try with USB hub. Hope it will work. Best of luck. (Worked for iphone 4s:ios9.3.5 on Macbook pro mid2015, Mac OS Mojave ) – Hriju Sep 11 '19 at 16:49

Your computer is not giving it enough power

  • How do i give it more power? – Aamir Ali Jun 22 '15 at 1:33
  • You can't through your computer. Either use a newer computer or use the wall charger – Mitchell D Jun 22 '15 at 7:33
  • This is a new laptop that i purchased only a few weeks ago and the only reason i need it connecting to my laptop is because i need to update my itunes – Aamir Ali Jun 22 '15 at 12:19
  • You should still be able to update the content on your phone through iTunes even if the phone isn't charging. Have you tried with a different USB cable? – Mitchell D Jun 22 '15 at 12:20
  • It starts to connect to my laptop but then goes off and on constantly, nope as i just bought this usb cable a few weeks ago aswell. – Aamir Ali Jun 22 '15 at 12:28

I have found a solution to this problem (I was also struggling with this for a while). It's basically because the macbook is trying to create a data connection with the iphone through the usb port. Here are some things that seems to work in my case:

  1. Using a USB extender and then connecting the iphone to it.
  2. Or Force quitting itunes and then plugging in the iphone.
  3. Or Ejecting the iphone from the itunes.

I have come to understand that it is not a problem due to the cable, nor due to a broken USB port (so stop changing that). Just stop the data connection process between the iphone and mac using the above 3 ways or any other way you find. Let me know if it works.



I purchased a Lifeproof Fre Power case for iPhone 6s (Feb 2016). You must use a micro USB cable to charge the case, not a Lightning cable. I had the same problem as Aamir Ali. Drove me nuts.

But you are right. Use a powerful charger and the "ON/OFF" charging problem goes away. Same cable at home didn't work with cigar lighter charger in truck/auto, even though it is a 5.4 Amp Belkin model. Or so they state.

When powered through top-quality and high amp chargers the problem goes away. The cable type or model does not seem to matter. Only the power source.

Lifeproof has been "nice", but has no good technical answer for this problem. "You must use our cable and charger." Hmm.


This happened to me with iPhone 5c. The way I charged was under a stack of books (6 or so). We went to the Apple Store to see if we could get it fixed but they said that getting it fixed would cost more than the actual phone. So I ended up just getting a whole new phone. But if you don't want to do that then like I said you could charge it under a stack of book with one on the bottom

  • Suppressing the vibrations doesnt answer the OP's question of why and how to stop it. – anki Jun 17 '19 at 18:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .