2

I imported a large number of old photos into iPhoto, and I then updated to the new Photos app recently. After the update, the thumbnails on the old photos are incorrect. They are just thumbnails of different pictures.

I cannot find a way to fix this. I tried launching Photos with CMD and Option held down and allowing the repair to complete. The problem persisted.

I have added an image that shows a thumbnail that doesn't match the selected photo. Any ideas?

enter image description here

  • Does removing and adding again the pictures work? – Jaime Santa Cruz Jun 11 '15 at 0:26
  • How do I remove and add the picture again? Export the pictures to another location and then re-add them? I guess I'll try it for one, but that is a large task for my library size as a fix for all the pictures. – Zach Green Jun 11 '15 at 0:33
  • That did work. I would still like a better resolution than exporting, deleting, and then reimporting my entire 100 GB library. – Zach Green Jun 11 '15 at 0:41
  • If it works, make a copy of your photo library, delete everything —via the Photos app— add everything back. Be careful because if you upgraded from iPhoto the library is probably split in two: everything you had before the upgrade inside the old iPhoto library; symlinks pointing to the old library and photos after the upgrade on the new Photos app library. – Jaime Santa Cruz Jun 11 '15 at 0:43
  • Sorry, I was writing while you commented; I agree it would be better to have a way to recreate the thumbnail db. – Jaime Santa Cruz Jun 11 '15 at 0:44
2
+25

To Rebuild the Photos.app Thumbnails:

Backup your library before following these instructions.

Delete the old thumbnails and various parts from the library:

Quit the Photos app.

Open Finder, and go to the Photos.app Library, on my system it is called Photos Library and is found in the Pictures folder.

Now right click the library and click Show Package Contents.

Next delete the folders called Previews and Thumbnails.

Then delete the files called ImageProxies.apdb, ImageProxies.apdb-wal, Library.apdb and Library.apdb-wal from the database folder.

Lastly delete the folders RKCloudResource, RKImageProxyState, RKMaster and RKVersion from the recovery folder.

Now rebuild the library

Open the Photos app while pressing +. It will ask you to if you want to repair the library, click Repair. It will do a repair, then your photos will go through a reprocess/reimport process. Once finished the thumbnails will start rebuilding.

P.S. I tried this on my own Photos library, and it worked.

  • 2
    Is there a source where you got the list of things to delete? I'm a little nervous about deleting so many internal files of the library. How long did the thumbnail rebuild take? – Zach Green Jun 25 '15 at 14:48
  • Zach you should do a backup first! – unknowndomain Jun 26 '15 at 21:12
  • @Zach Green, not really. I did a bit of research to write this answer, so there's a lot of links. I'd backup your library first, if you can't do that then don't try this solution. :) It did not take long for my library, but it only has about 300 photos because I use Capture One for my photos by default. Also I use SSD. – user133345 Jun 27 '15 at 2:17
0

Simply rotate all your photo's to the right using ++R and then to the left using +R. This could take some time, but it isn't as hard as exporting and importing the whole library.

  • 1
    This isn't a reasonable solution for 30,000 photos. – Zach Green Jun 24 '15 at 22:00
0

From the discussion forums at Apple:

Are you still able to use iPhoto on your iPhoto Library? If so run the first aid on that library with iPhoto and apply Options #1, Repair Library Permissions, #2 - Rebuild Thumbnails and #4 - Rebuild Library Database.

Then open that "fixed" library with Photos to create a new Photos library. See if that will bring the thumbnails back.

-1

Try changing the shape of the thumbnails. There is an option "Display Square Thumbnails in Split view" under the View menu option. I can't be sure, but this may cause the app to redraw the thumbnails, and may resolve your problem (lets hope so anyway).

View menu

  • 1
    Tried. No luck. Thanks though – Zach Green Jun 24 '15 at 1:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .