When i try to reduce my mac book volume it suddenly shows that this isn't possible, even the icon in the menu bar is (grey inactive)

This happens sometimes since i installed lion os

enter image description here

6 Answers 6


I have experienced this issue starting with my new install of Lion. I haven't been able to find the cause of the issue but I do have a quick way to reset the audio system and get back volume control.

Open Activity Monitor (Its in Applications/Utilities)

Make sure it is set to All Processes, look for coreaudiod, click "Quit Process" then "Quit". Wait a few seconds and you should have volume control back.

If your a terminal buff a quick sudo killall coreaudiod should whip it into shape.


The first thing to check is the selected output device in System Preferences. To do that, open System Preferences and click on "Sound".

enter image description here

Next, go through each of the tabs to verify that you don't see any obvious settings. I've seen this before on Snow Leopard, and although I'm now on Lion, I don't think this changed much.

enter image description here

I don't remember what the setting were, but it was fairly obvious to me what to change.

  • For me it was trying to output over DisplayPort to my monitor that doesn't have speakers. I switched to Internal Speakers and it worked.
    – stephenbez
    Commented Dec 8, 2016 at 21:43
  • This effectively fixed the issue for me. Just like what stephen mentioned in the above, my Mac was also trying to output to my monitor
    – konekoya
    Commented Aug 11, 2020 at 7:22

Check inside the headphone jack. Is a red light showing? If so, the MacBook might be trying to output optical audio. Make sure nothing is stuck in there - lint, dust, etc. Plugging in and then removing headphones may also help. If the red light stays, best to bring it in for service.


As you suggested, I cHecked inside the headphone jack and found a red light showing. Plugging in and then removing headphones solved the problem. Thank you for the advice.


When I had to use Force Quit to close a stuck Premier Elements 9, it somehow reset the audio. Go to System Preferences → Sound → Output and re-choose Internal Speakers to get the sound going again, as well as the buttons on the keyboard to control the speakers.


I personally tried most of the listed above. What I ended up doing before I did anything too crazy (i'm not super techy) is I just put in my earbuds again and took them out. I didn't have a read light going near the headphone jack, but it did the job. Now I have control again! I hope that helps you, my friends!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .