11

I know there is an option to disable autocorrect for all applications, but how do I disable autocorrect for only one application?

0
16

Turn off Autocorrect per Application

You can do this in "Edit" menu for that Application under "Spelling and Grammar" and disable "Check Spelling While Typing".

2
  • 1
    I didn't think it was possible, but you have shed the light. Thank you. – Ralph David Abernathy Jun 10 '15 at 5:06
  • 1
    sorry what is the Applications edit menu? – Hao S Aug 26 '19 at 21:50
3

I want to expand on @Grizzwald's answer as that sadly won't always work.


IF "Correct Spelling Automatically" is grayed out for your Application (which was the case for me using the Todoist app).

  • Found here: Edit->Spelling and Grammer->Correct Spelling Automatically

THEN you'll (unfortunately) need to turn this off for all Applications under:

  • System Preferences->Keyboard->Text->Correct Spelling Automatically
1
  • 1
    This was disabled (grayed out) for the application I was using since I wasn't centered on a text input field. Once I was in "writing mode" it became available. – Steve Tauber Jan 2 '18 at 22:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .