1

I've plugged an USB NFC/RFID reader, model ACR112U-A9 provided by ACS Ltd.

Although it is plugged I can't read anything and I keep getting this logs in console:

09/06/15 14:13:00,901 com.apple.SecurityServer[83]: reader ACS ACR122U PICC Interface: state changed 16 -> 34
09/06/15 14:13:00,902 com.apple.SecurityServer[83]: token in reader ACS ACR122U PICC Interface cannot be used (error 229)
09/06/15 14:13:01,249 com.apple.SecurityServer[83]: reader ACS ACR122U PICC Interface: state changed 32 -> 18

How can I solve this issue? Do you know what is the error 229 and why it's triggered?

4
  • I'm getting the same error. Are you able to resolve this?
    – ksuralta
    Commented Jun 16, 2015 at 1:51
  • Unfortunately not yet. But you can up vote this question to increase its visibility. I'll keep you updated. Commented Jun 16, 2015 at 6:52
  • hey, guys, did you manage to solve this?
    – Ned
    Commented Jul 3, 2015 at 22:48
  • Solved, check the answer below. Commented Jul 5, 2015 at 9:03

2 Answers 2

0

I found a solution: You need to download the ACS ACR122U Drivers for Mac OS X 10.x.

Here the download page and the direct link for PC/SC Driver Installer 1.1.0 (Mac 10.5, Mac 10.6, Mac 10.7, Mac 10.8, Mac 10.9, Mac 10.10) (2014-09-17 306KB).

You have to install it even if the installer is not properly signed.

It will install the useful driver in: /usr/libexec/SmartCardServices/drivers/ifd-acsccid.bundle

Now you are able to use the card reader. If you want to test it out, I made a simple project here.

0

The problem with the above answer is that it doesn't work with Mac OS X 10.11.x, as SIP (System Integrity Protection) mechanism blocks any attempts to write to system directories such as /usr/libexec/...

I found that the workaround proposed by Metsma here Re: el capitan 10.11.4 unable to see smartcard solved the problem of "interface or token cannot be used (error 229)" on 10.11.5. Also, once the right symlink was placed - I did not need to install any additional driver. The existing libccid.dylib.1.14.21 proved sufficient.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .