1

Background

I have a 5th generation AirPort Time Capsule, bought refurbished from Apple about 6 months ago. It is on software version 7.7.3 and has worked without issue until recently.

Problem

Two days ago the performance of my AirPort Time Capsule's wifi dropped dramatically. Whereas before I had no problem with AirPlay, or streaming videos stored on the Capsule over wifi, now videos buffer every few seconds, and AirPlay is chopped up to smithereens. Web browsing is also noticeably slower, and file transfer speeds to and from the device have fallen through the floor.

Diagnosis

The problem seemed to start a day or so after I added an HP Envy 5530 printer to my network, though this could just be a coincidence.

To get an idea of exactly how slow the wifi had become, I put my Mac directly next to the Capsule and timed copying a 2GB (16000Mb) file to and from the device:

  • To: 390s ≈ 41Mbps
  • From: 527s ≈ 30Mbps

Both are less than a tenth of the theoretical maximum of 450Mbps reported when I alt-click the wifi icon in the top bar, so something is clearly amiss.

To isolate the wifi as the culprit, I connected my Mac to the Capsule over an Ethernet cable. I then saw that videos streamed without issue, files transferred at reasonable speed, and web browsing returned to normal.

To isolate environmental interference and/or my Mac's wifi client as the problem, I took the Capsule into the office and repeated the transfer using a 360MB file on a Windows laptop. The results were even worse than above:

  • To: 88s ≈ 31Mbps
  • From: 136s ≈ 20Mbps

Here is a screenshot from iStumbler taken at home while a slow file transfer was in progress. The top two networks are mine (5GHz and 2.4GHz) and it shows there is no channel contention. The transfer occurred around the middle 50% of the graph.

enter image description here

Remedy

I tried a few things to fix the problem, but with no luck:

  1. Ran Wireless Diagnostics but no problems were found.
  2. Assigned the wifi channels manually to a few different random combinations.
  3. Specified a different SSID for the 5GHz wifi and tried connecting through that.
  4. Removed the HP software and deleted the printer from my Mac, and unplugged the printer from the wall.
  5. Performed a factory reset of the Capsule.

Next steps

Short of returning the unit to Apple, is there anything else I should try?

0

Changing network parameters like channel assignments might cause more harm than good, especially on the long turm. You may end up in having to analyse strange issues...

Use a professionnal tool to analyse your wireless environment first: iStumbler.

If you want a professionnal help, please put a copy of a screen capture with this tool. Make this environmental measure at a point which is as near as possible from the point you want to communicate with your Time Capsule usually. Take care to make this measure at the hour you witness your slow network throughput. Sort the output along decreasing signal level (Level column).

Take care to hide private information from this screen capture.

If you have a real environmental problem (which a real and highly frequent situation), fix it.

Else, bring back your Time Capsule to your Apple reseller. Most probably an antenna cable was not correctly fixed inside, and a move made it unplug.

0

I finally found the problem. Quite inexplicably, it was caused by the latest update to Boom 2 (v1.2). This introduced an option to use the Boom Remote iPhone app. Even if you don't have the app, it's enabled by default in the interface. Disabling it solves all issues:

enter image description here

There are plenty of other people are reporting the same thing on their forum, and the company has acknowledged the issue.

  • Hence this software is doing real mad traffic to try to check if a neighbooring iPhone is a known friend. This is an hyperactive application. A tcpdump -i p2p0 or iStumbler on Bluetooth, will show you how your wireless environment is working and… sweating. I hope you don't have equipment working above 32mW in the 802.11x era. – dan Jun 18 '15 at 6:56
  • Is "Quite inexplicably" the official answer from Boom? – dan Jun 18 '15 at 6:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .