6

I just purchased a new Macbook Pro with Force Touch.

I’m used to the old tap-to-click feature. Force Touch does not feel the same – it requires a much harder press even with “Click” sensitivity set to “light.”

Tap-to-click, is also not working on my Magic Trackpad.

How do I make Apple Force Touch feel like the old tap-to-click?

How do I make tap-to-click work on a Magic Trackpad connected to a Macbook Pro 2015 with Force Touch?

1
  • The tap to click you originally mentioned actually works. There's a slightly longer delay now though (which sucks cause it makes it seem like it doesn't work). So if you tap and wait for an extra couple of milliseconds, you'll notice the tap has been registered. it's total BS though :(. I think the "spring-loading delay" answer mentioned reduces that delay just a tad bit, but it's not the same feeling as the old tap to click days. Sep 30, 2015 at 5:34

2 Answers 2

0

Go to system preferences and navigate to accessibility.

Disable "Spring-loading delay."

Enable tap-to-click by disabling Spring-loading delay

6
  • 1
    Spring-loading delay is how long it takes for a folder to open when you drag something over it - it has nothing to do with tap to click. I suspect you changed something else that fixed your problem.
    – Aidan Kane
    Jun 23, 2015 at 9:24
  • @AidanKane This is directly from my conversation with Apple support. Jun 24, 2015 at 2:17
  • 1
    Really?! That's insane. Is there any chance you could turn it off again to double check? I'd be really interested to know if it definitely works. If it does there's something very long with the label and help description they've used for that checkbox! :-)
    – Aidan Kane
    Jun 24, 2015 at 7:39
  • @AidanKane Yeah, I'll take another look at it. Jun 24, 2015 at 17:27
  • 1
    @AidanKane Nope, this is what does it. Without the haptic feedback, it feels like there's no click at all. The "spring-loading delay" is to simulate of depressing the mouse and then clicking. If you're a tap-clicker like myself, that delay is just annoying. :) May 16, 2016 at 14:39
0

enter image description here

Disabling the "Force Click and haptic feedback" checkbox reverts to the original behavior.

1
  • This does not work. Mar 21, 2016 at 15:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .